现在的位置: 首页 > 综合 > 正文

HDU 1258Sum It Up(暴力dfs,记住相同的状态只保留一个)

2013年12月12日 ⁄ 综合 ⁄ 共 2595字 ⁄ 字号 评论关闭

Sum It Up

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3300    Accepted Submission(s): 1665


Problem Description
Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2, and 2+1+1.(A number
can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.
 


Input
The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise, t will be a positive integer
less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order, and there may be repetitions.
 


Output
For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order. A number may be repeated
in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums with the same first number
must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.
 


Sample Input
4 6 4 3 2 2 1 1 5 3 2 1 1 400 12 50 50 50 50 50 50 25 25 25 25 25 25 0 0
 


Sample Output
Sums of 4: 4 3+1 2+2 2+1+1 Sums of 5: NONE Sums of 400: 50+50+50+50+50+50+25+25+25+25 50+50+50+50+50+25+25+25+25+25+25
 


Source
 
题目大意:给你一个数的和sum,最大1000,然后是n(n<=12)个<=100的正数数,a[0],a[1]...a[n-1],选取这里面的数,使得和为sum,开始准备暴力枚举。。不用那么麻烦,可以直接暴搜,不过遇到同一个状态则保留一个,在搜索的时候每一个点访问之后,这个值在这个相同的位置不能再次被访问。因为这点一样后面的情况肯定一样了。具体实现见代码。

题目地址:Sum It Up

AC代码:
#include<iostream>
#include<cstring>
#include<string>
#include<cstdio>
#include<algorithm>
using namespace std;
int a[15],sum,n;
int ans[15];
int flag,tt;

bool cmp(int a,int b)
{
    return a>b?1:0;
}

void dfs(int t,int s)
{
    int i;
    if(s>sum) return;
    if(s==sum)
    {
        cout<<ans[0];
        for(i=1;i<tt;i++)
            cout<<"+"<<ans[i];
        cout<<endl;
        flag=1;   //说明找到了一个
    }

    int last=-1;
    for(i=t+1;i<n;i++)
    {
        if(a[i]!=last)  //相应的同一个位置的节点不允许相同
        {
            last=a[i];
            ans[tt++]=a[i];
            dfs(i,s+a[i]);
            tt--;
        }
    }
}

int main()
{
    int i;
    while(scanf("%d%d",&sum,&n))
    {
        flag=0;
        if(!sum&&!n) break;
        for(i=0;i<n;i++)
            scanf("%d",&a[i]);
        sort(a,a+n,cmp);
        printf("Sums of %d:\n",sum);
        int last=-1;
        for(i=0;i<n;i++)
        {
            if(a[i]!=last)  //每次起点不同
            {
                last=a[i];
                tt=0;
                ans[tt++]=a[i];
                dfs(i,a[i]);
            }
        }
        if(!flag)
            puts("NONE");
    }
    return 0;
}

//0MS

抱歉!评论已关闭.