现在的位置: 首页 > 综合 > 正文

hdu 3018 Ant Trip

2013年12月05日 ⁄ 综合 ⁄ 共 2293字 ⁄ 字号 评论关闭

Ant Trip

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 886 Accepted Submission(s): 332

Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now
tony wants to know what is the least groups of ants that needs to form to achieve their goal.

Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each
line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

Output
For each test case ,output the least groups that needs to form to achieve their goal.

Sample Input
3 3 1 2 2 3 1 3 4 2 1 2 3 4

Sample Output
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.

Source

Recommend
gaojie

题目大意。一群蚂蚁想把蚂蚁国的每条路都走完。每条路只能走一次。问蚂蚁至少要分为几队。

并查集判断基图个数。再查每个基图中需要蚂蚁队数为。欧拉回路数+度数为奇数的节点数/2;

(一笔画无问题)

#include <stdio.h>
#include<string.h>
int sets[100100],digree[100100],sz[100100],ed[100100];//sets用于建立并查集
//digree用于记录节点度数。sz记录集合中元素个数。ed记录度数为奇数节点的个数
int a[200100],b[200100];//记录输入数据
int findx(int x)//并查集。查找根
{
    int p,i,t;
    p=x;
    while(p!=sets[p])
        p=sets[p];
    i=x;
    while(i!=p)
    {
        t=sets[i];
        sets[i]=p;
        i=t;
    }
    return p;
}
void toone(int a,int b)//合并集合。并更新集合奇节点数
{
    int p,q;
    p=findx(a);
    q=findx(b);
    if(p==q)
        return;
    if(sz[p]>sz[q])
    {
        sets[q]=p;
        sz[p]+=sz[q];
        ed[p]+=ed[q];
    }
    else
    {
        sets[p]=q;
        sz[q]+=sz[p];
        ed[q]+=ed[p];
    }
}
int main()
{
    int n,m,i,sum;

    while(~scanf("%d%d",&n,&m))
    {
        sum=0;
        memset(digree,0,sizeof digree);
        for(i=1;i<=n;i++)
        {
            sets[i]=i;
            sz[i]=1;
            ed[i]=0;
        }
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&a[i],&b[i]);
            digree[a[i]]++;
            digree[b[i]]++;
        }
        for(i=1;i<=n;i++)
            if(digree[i]%2)
            ed[i]=1;//标记奇节点号
        for(i=1;i<=m;i++)//合并集合
            toone(a[i],b[i]);
        for(i=1;i<=n;i++)
        {
            if(digree[i]&&sets[i]==i)//遍历集合set[i]=i说明是根节点
            {
                if(ed[i]==0)//欧拉回路
                    sum++;
                else
                    sum+=ed[i]/2;//一笔画公式
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}

抱歉!评论已关闭.