现在的位置: 首页 > 综合 > 正文

hdu 1016 Prime Ring Problem

2013年12月05日 ⁄ 综合 ⁄ 共 1459字 ⁄ 字号 评论关闭

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18778 Accepted Submission(s): 8402

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

Input
n (0 < n < 20).

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in
lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input
6 8

Sample Output
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

Source

Recommend
JGShining

#include <stdio.h>
#include<string.h>
int a[41],visit[25],way[25];
int n,cw;

void print()
{
    int i;
    for(i=0;i<cw-1;i++)
        printf("%d ",way[i]);
    printf("%d\n",way[i]);
}
void dfs(int p,int pre)//p记录已经填到的位置
{
    int i;
    if(p==n-1)
    {
        for(i=1;i<=n;i++)
        {
            if(!visit[i]&&!a[i+1]&&!a[pre+i])//visit表示是否已填
            {
                way[cw++]=i;
                print();
                cw--;
                return;
            }
        }
        return;
    }
    for(i=1;i<=n;i++)
    {
        if(!visit[i]&&!a[i+pre])
        {
            visit[i]=1;
            way[cw++]=i;
            dfs(p+1,i);
            visit[i]=0;
            cw--;
        }
    }
}
int main()
{
    int i,j,Case=1;
    memset(a,0,sizeof a);
    a[1]=1;
    for(i=2;i<=40;i++)
        if(!a[i])//用a来判断一个数是否为素数。题目数据较小所以很方便
           for(j=2*i;j<=40;j+=i)
                a[j]=1;
        while(~scanf("%d",&n))
        {
            cw=1;
            memset(visit,0,sizeof visit);
            printf("Case %d:\n",Case++);
            visit[1]=1;
            way[0]=1;
            dfs(1,1);
            printf("\n");
        }
    return 0;
}

抱歉!评论已关闭.