现在的位置: 首页 > 综合 > 正文

The Falling Leaves UVA699

2013年12月03日 ⁄ 综合 ⁄ 共 2740字 ⁄ 字号 评论关闭

  The Falling Leaves 


Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary
trees, how large would the piles of leaves become?

We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes
are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3
is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it
is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

Input 

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the
right subtree. If a subtree is empty, the value 
-1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1.
Each actual tree node contains a positive, non-zero value. The last test case is followed by a single 
-1 (which would otherwise represent an empty tree).

Output 

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single
space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

Sample Input 

5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1

Sample Output 

Case 1:
7 11 3

Case 2:
9 7 21 15


Miguel Revilla 
2000-08-14

这道题题意很好理解,在判定二叉树的节点数是不是结束的时候我用到了一个定理,二叉树也节点数也就是题中-1的个数等于度数为一和二的结点个数加一,题中不存在度数为一的结点,因此很好判断树的结点是否结束,然后用dfs深搜这棵树,不用建树。

#include<iostream>
#include<cstring>

using namespace std;

int arry[10000];
int arry1[200];
int pos;

void dfs(int &s,int len,int pos3)
{
    ++s;
    if(s==len) return;
    if(arry[s]==-1) return;
    if(arry[s]!=-1)
    {
        arry1[pos3]=arry1[pos3]+arry[s];
    }
    dfs(s,len,pos3-1);
    dfs(s,len,pos3+1);
}

int main()
{
    int n,m=0;
    while(cin>>n&&n!=-1)
    {
        memset(arry,0,sizeof(arry));
        memset(arry1,0,sizeof(arry1));
        int i=1,j=0,k=0;
        arry[k++]=n;
        while(cin>>n)
        {
            arry[k++]=n;
            if(n==-1) j++;
            else i++;
            if(j==(i+1)) break;
        }
        pos=-1;
        dfs(pos,k,100);
        cout<<"Case "<<++m<<":"<<endl;
        int tag=0;
        for(i=0;i<200;i++)
        {
            if(arry1[i]!=0&&tag==0) 
            {
                cout<<arry1[i];
                tag=1;
            }
            else if(arry1[i]!=0&&tag==1)
            {
                cout<<" "<<arry1[i];
            }
        }
        cout<<endl;
        cout<<endl;
    }
    return 0;
}

抱歉!评论已关闭.