现在的位置: 首页 > 综合 > 正文

Matrix Chain Multiplication UVA 442

2013年12月01日 ⁄ 综合 ⁄ 共 2547字 ⁄ 字号 评论关闭

 Matrix Chain Multiplication 


Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices. Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the
number of elementary multiplications needed strongly depends on the evaluation order you choose.

For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix. There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).

The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.

Input Specification

Input consists of two parts: a list of matrices and a list of expressions.

The first line of the input file contains one integer n ( tex2html_wrap_inline28 ), representing
the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.

The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } <EOF>
Line       = Expression <CR>
Expression = Matrix | "(" Expression Expression ")"
Matrix     = "A" | "B" | "C" | ... | "X" | "Y" | "Z"

Output Specification

For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print
one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.

Sample Input

9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))

Sample Output

0
0
0
error
10000
error
3500
15000
40500
47500
15125

这道题目被我想复杂了,不需要考虑括号的不对称问题,只需要考虑相乘时候两个矩阵合不合法。这个符号表达式我看的好难受。

#include<iostream>
#include<string>
#include<algorithm>
#include<stack>
#include<map>

using namespace std;

class T
{
public:
    int x,y;
};

class P
{
public:
    string s;
    int x1,y1;
};

stack<P> team;
map<string,T> tree;

int main()
{
    int n,a,b;
    string s1,str;
    T z;
    cin>>n;
    while(n--)
    {
        cin>>s1>>a>>b;
        z.x=a,z.y=b;
        tree.insert(make_pair(s1,z));
    }
    int i,j,k,sum,a1,b1,a2,b2;
    P c;
    while(cin>>str)
    {
        sum=0;
        int flag=1;
        string str2="";
        for(i=0;i<str.size();i++)
        {
            if(str[i]>='A'&&str[i]<='Z')
            {
                str2=str2+str[i];
                a1=tree[str2].x;
                b1=tree[str2].y;
                c.s=str2;
                c.x1=a1;
                c.y1=b1;
                team.push(c);
                str2="";
            }
            else if(str[i]==')')
            {
                str2=(team.top()).s;
                a1=(team.top()).x1;
                b1=(team.top()).y1;
                team.pop();
                if(a1!=((team.top()).y1))
                {
                    cout<<"error"<<endl;
                    flag=0;
                    break;
                }
                a2=(team.top()).x1;
                b2=(team.top()).y1;
                str2=str2+((team.top()).s);
                sum=sum+a2*b2*b1;
                c.s=str2;
                c.x1=a2;
                c.y1=b1;
                team.pop();
                //team.pop();
                team.push(c);
                str2="";
            }
        }
        if(flag)
        {
            cout<<sum<<endl;
        }
        while(!team.empty())
        {
            team.pop();
        }
    }
    return 0;
}

抱歉!评论已关闭.