现在的位置: 首页 > 综合 > 正文

Pseudo-Random Numbers UVA350

2013年12月01日 ⁄ 综合 ⁄ 共 1893字 ⁄ 字号 评论关闭

 Pseudo-Random Numbers 


Computers normally cannot generate really random numbers, but frequently are used to generate sequences of pseudo-random numbers. These are generated by some algorithm, but appear for all practical purposes to be
really random. Random numbers are used in many applications, including simulation.

A common pseudo-random number generation technique is called the linear congruential method. If the last pseudo-random number generated was L, then the next number is generated by evaluating ( tex2html_wrap_inline32 ,
where Z is a constant multiplier, I is a constant increment, and M is a constant modulus. For example, suppose Z is 7, I is 5, and M is 12. If the first random number (usually called the seed)
is 4, then we can determine the next few pseudo-random numbers are follows:

tabular21

As you can see, the sequence of pseudo-random numbers generated by this technique repeats after six numbers. It should be clear that the longest sequence that can be generated using this technique is limited by
the modulus, M.

In this problem you will be given sets of values for ZIM, and the seed, L. Each of these will have no more than four digits. For each such set of values you are to determine
the length of the cycle of pseudo-random numbers that will be generated. But be careful: the cycle might not begin with the seed!

Input

Each input line will contain four integer values, in order, for ZIM, and L. The last line will contain four zeroes, and marks the end of the input data. L will be
less than M.

Output

For each input line, display the case number (they are sequentially numbered, starting with 1) and the length of the sequence of pseudo-random numbers before the sequence is repeated.

Sample Input

7 5 12 4
5173 3849 3279 1511
9111 5309 6000 1234
1079 2136 9999 1237
0 0 0 0

Sample Output

Case 1: 6
Case 2: 546
Case 3: 500
Case 4: 220

据说这道题要用到哈希(其实到现在我都不懂啥叫哈希。。。),先声明一个10000的数组,来记录出现一万以内出现的状态,和出现的次数,用第二次出现次数减去第一次就得到了一个循环次数。。

#include<iostream>
#include<cstring>

using namespace std;

int arry[10050];

int main()
{
    int z,i,m,l,j=0;
    while(cin>>z>>i>>m>>l&&(z||i||m||l))
    {
        j++;
        memset(arry,0,sizeof(arry));
        int t=1;
        while(!arry[l])
        {
            arry[l]=t++;
            l=(z*l+i)%m;
        }
        cout<<"Case "<<j<<": "<<t-arry[l]<<endl;
    }
    return 0;
}



抱歉!评论已关闭.