现在的位置: 首页 > 综合 > 正文

TOJ 1763 ZOJ 1976 Paths on a Grid

2013年12月11日 ⁄ 综合 ⁄ 共 1602字 ⁄ 字号 评论关闭

Paths on a Grid

时间限制(普通/Java):1000MS/10000MS     运行内存限制:65536KByte

描述

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b)2=a2+2ab+b2).
So you decide to waste your time with drawing modern art instead.

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner,
taking care that it stays on the lines and moves only to the right or up. The result is shown on the left:




Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

输入

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding
grid is one more in each dimension. Input is terminated by n=m=0.

输出

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each
step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

样例输入

5 4
1 1
0 0

样例输出

126
2

给你个n*m的表格 问从左下角到右上角有多少条路

证明出来有 (m+n,m)或者C(m+n,n)种

证明http://www.cnblogs.com/luotinghao/p/3224290.html

#include <iostream>
#include <stdio.h>
using namespace std;
long long CNM(long long N, long long M)
{
	M = (M > N - M) ? N - M : M;
    long long ret = 1,i = 1;
    while(i <= M)
	{
		ret *= (N--) ;
		ret /= (i++);
	}
    return ret;
}
int main()
{
	long long A, B;
    while(scanf("%lld %lld", &A, &B),A||B)
         printf("%lld\n",CNM(A + B, B));
    return 0;
}

 

抱歉!评论已关闭.