现在的位置: 首页 > 综合 > 正文

uva 10177 (2/3/4)-D Sqr/Rects/Cubes/Boxes?(空间几何规律)

2013年12月12日 ⁄ 综合 ⁄ 共 1667字 ⁄ 字号 评论关闭

(2/3/4)-D Sqr/Rects/Cubes/Boxes?

Input: standard input

Output: standard output

Time Limit: 2 seconds

 

You can see a (4x4) grid below. Can you tell me how many squares and rectangles are hidden there? You can assume that squares are not rectangles. Perhaps one can count it by hand but can you count it for a (100x100) grid or a
(10000x10000) grid. Can you do it for higher dimensions? That is can you count how many cubes or boxes of different size are there in a (10x10x10) sized cube or how many hyper-cubes or hyper-boxes of different size are there in a four-dimensional (5x5x5x5)
sized hypercube. Remember that your program needs to be very efficient. You can assume that squares are not rectangles, cubes are not boxes and hyper-cubes are not hyper-boxes. 

 

Fig: A 4x4 Grid

Fig: A 4x4x4 Cube

 

 

Input

The input contains one integer N (0<=N<=100) in each line, which is the length of one side of the grid or cube or hypercube. As for the example above the value of N is 4. There may be as many
as 100 lines of input.

 

Output

For each line of input, output six integers S2, R2, S3, R3, S4, R4 in a single line where S2 means no of squares of different size in ( NxN) two-dimensional grid, R2 means
no of rectangles of different size in (NxN) two-dimensional grid. S3, R3, S4, R4 means similar cases in higher dimensions as described before.  

 

Sample Input:

1
2
3

Sample Output:

1 0 1 0 1 0
5 4 9 18 17 64
14 22 36 180 98 1198

题目大意:求空间上2、3、4维空间上的正方形个数和纯矩形(不包括正方形),三维上叫正方体和长方体(4维就不知道了)。

解题思路:正方sum(pow(i, 维数))(1 <= i <= n)

矩形pow((n*(n - 1))/ 2, 维数+1)- 正方形个数。

#include<stdio.h>
#include<string.h>
#include<math.h>

int main(){
	long long n, s[3], q[3];
	while (scanf("%lld", &n) != EOF){
		// Init.
		memset(s, 0, sizeof(s));
		memset(q, 0, sizeof(q));
		long long k = n * ( n + 1 ) / 2;

		for (int i = 1; i <= n; i++)
			for (int j = 0; j < 3; j++)
				s[j] += pow(i, j + 2);
			
		for (int i = 0; i < 3; i++)
			q[i] = pow(k, i + 2) - s[i];

		for (int i = 0;i < 2; i++)
			printf("%lld %lld ", s[i], q[i]);
		printf("%lld %lld\n", s[2], q[2]);
	}
return 0;}	

抱歉!评论已关闭.