现在的位置: 首页 > 综合 > 正文

poj 3204 Ikki’s Story I – Road Reconstruction 找可使流量增加的割边个数 最小割+dfs

2013年02月13日 ⁄ 综合 ⁄ 共 3829字 ⁄ 字号 评论关闭

Description

Ikki is the king of a small country – Phoenix, Phoenix is so small that there is only one city that is responsible for the production of daily goods, and uses the road network to transport the goods to the capital. Ikki finds that the biggest problem in
the country is that transportation speed is too slow.

Since Ikki was an ACM/ICPC contestant before, he realized that this, indeed, is a maximum flow problem. He coded a maximum flow program and found the answer. Not satisfied with the current status of the transportation speed, he wants to increase the transportation
ability of the nation. The method is relatively simple, Ikki will reconstruct some roads in this transportation network, to make those roads afford higher capacity in transportation. But unfortunately, the country of Phoenix is not so rich in GDP that there
is only enough money to rebuild one road. Ikki wants to find such roads that if reconstructed, the total capacity of transportation will increase.

He thought this problem for a loooong time but cannot get it. So he gave this problem to frkstyc, who put it in this POJ Monthly contest for you to solve. Can you solve it for Ikki?

Input

The input contains exactly one test case.

The first line of the test case contains two integers NM (N ≤ 500, M ≤ 5,000) which represents the number of cities and roads in the country, Phoenix, respectively.

M lines follow, each line contains three integers abc, which means that there is a road from city a to city b with a transportation capacity of c (0 ≤ ab < nc ≤
100). All the roads are directed.

Cities are numbered from 0 to n − 1, the city which can product goods is numbered 0, and the capital is numbered n − 1.

Output

You should output one line consisting of only one integer K, denoting that there are K roads, reconstructing each of which will increase the network transportation capacity.

Sample Input

2 1
0 1 1

Sample Output

1

//

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=21010;
const int M=250000;
const int inf=(1<<28);
int head[N];
struct Edge
{
    int u,v,next,w,id;
} edge[M];
int cnt,n,s,t;//n从0开始  0->n-1
void addedge(int u,int v,int w,int id)
{
    edge[cnt].u=u;
    edge[cnt].v=v;
    edge[cnt].w=w;
    edge[cnt].id=id;
    edge[cnt].next=head[u];
    head[u]=cnt++;
    edge[cnt].u=v;
    edge[cnt].v=u;
    edge[cnt].id=id;
    edge[cnt].w=0;
    edge[cnt].next=head[v];
    head[v]=cnt++;
}
int sap()
{
    int pre[N],cur[N],dis[N],gap[N];
    int flow=0,aug=inf,u;
    bool flag;
    for(int i=0; i<n; i++)
    {
        cur[i]=head[i];
        gap[i]=dis[i]=0;
    }
    gap[s]=n;
    u=pre[s]=s;
    while(dis[s]<n)
    {
        flag=0;
        for(int &j=cur[u]; j!=-1; j=edge[j].next)
        {
            int v=edge[j].v;
            if(edge[j].w>0&&dis[u]==dis[v]+1)
            {
                flag=1;
                if(edge[j].w<aug) aug=edge[j].w;
                pre[v]=u;
                u=v;
                if(u==t)
                {
                    flow+=aug;
                    while(u!=s)
                    {
                        u=pre[u];
                        edge[cur[u]].w-=aug;
                        edge[cur[u]^1].w+=aug;
                    }
                    aug=inf;
                }
                break;
            }
        }
        if(flag) continue;
        int mindis=n;
        for(int j=head[u]; j!=-1; j=edge[j].next)
        {
            int v=edge[j].v;
            if(edge[j].w>0&&dis[v]<mindis)
            {
                mindis=dis[v];
                cur[u]=j;
            }
        }
        if((--gap[dis[u]])==0)
            break;
        gap[dis[u]=mindis+1]++;
        u=pre[u];
    }
    return flow;
}

//初始化  cnt=0;memset(head,-1,sizeof(head));
int vis1[N],vis2[N];
void dfs1(int u)
{
int i,v;
vis1[u]=true;
for(i=head[u];i!=-1;i=edge[i].next)
{
v=edge[i].v;
if(edge[i].w>0&&!vis1[v])
dfs1(v);
}
}
void dfs2(int u)
{
int i,v;
vis2[u]=true;
for(i=head[u];i!=-1;i=edge[i].next)
{
v=edge[i].v;
if(edge[i^1].w>0&&!vis2[v])
dfs2(v);
}
}
 int main()
 {
     int m,l;
     while(scanf("%d%d",&m,&l)==2)
     {
         cnt=0;
         memset(head,-1,sizeof(head));
         n=m;
         s=0,t=n-1;
         for(int i=1;i<=l;i++)
         {
             int u,v,w;scanf("%d%d%d",&u,&v,&w);
             addedge(u,v,w,i);
         }
         int tmp=sap();
         memset(vis1,0,sizeof(vis1));
         memset(vis2,0,sizeof(vis2));
         dfs1(s);
         dfs2(t);
         int ans[N];
         int ln=0;
         for(int i=0;i<cnt;i+=2)
         {
             int u=edge[i].u,v=edge[i].v;
             if(!edge[i].w&&vis1[u]&&vis2[v])
                 ans[ln++]=edge[i].id;
         }
         printf("%d\n",ln);
     }
 }

抱歉!评论已关闭.