现在的位置: 首页 > 综合 > 正文

hdu 4046 Panda 线段树 单点修改 求区间010个数

2013年01月25日 ⁄ 综合 ⁄ 共 5678字 ⁄ 字号 评论关闭
Problem Description
When I wrote down this letter, you may have been on the airplane to U.S.

We have known for 15 years, which has exceeded one-fifth of my whole life. I still remember the first time we went to the movies, the first time we went for a walk together. I still remember the smiling face you wore when you were dressing in front of the mirror.
I love your smile and your shining eyes. When you are with me, every second is wonderful.
The more expectation I had, the more disappointment I got. You said you would like to go to U.S.I know what you really meant. I respect your decision. Gravitation is not responsible for people falling in love. I will always be your best friend. I know the way
is difficult. Every minute thinking of giving up, thinking of the reason why you have held on for so long, just keep going on. Whenever you’re having a bad day, remember this: I LOVE YOU.
I will keep waiting, until you come back. Look into my eyes and you will see what you mean to me.
There are two most fortunate stories in my life: one is finally the time I love you exhausted. the other is that long time ago on a particular day I met you.
Saerdna.

It comes back to several years ago. I still remember your immature face.
The yellowed picture under the table might evoke the countless memory. The boy will keep the last appointment with the girl, miss the heavy rain in those years, miss the love in those years. Having tried to conquer the world, only to find that in the end, you
are the world. I want to tell you I didn’t forget. Starry night, I will hold you tightly.

Saerdna loves Panda so much, and also you know that Panda has two colors, black and white.
Saerdna wants to share his love with Panda, so he writes a love letter by just black and white.
The love letter is too long and Panda has not that much time to see the whole letter.
But it's easy to read the letter, because Saerdna hides his love in the letter by using the three continuous key words that are white, black and white.
But Panda doesn't know how many Saerdna's love there are in the letter.
Can you help Panda?

 

 

Input
An integer T means the number of test cases T<=100
For each test case:
First line is two integers n, m
n means the length of the letter, m means the query of the Panda. n<=50000,m<=10000
The next line has n characters 'b' or 'w', 'b' means black, 'w' means white.
The next m lines
Each line has two type
Type 0: answer how many love between L and R. (0<=L<=R<n)
Type 1: change the kth character to ch(0<=k<n and ch is ‘b’ or ‘w’)
 

 

Output
For each test case, output the case number first.
The answer of the question.
 

 

Sample Input
2 5 2 bwbwb 0 0 4 0 1 3 5 5 wbwbw 0 0 4 0 0 2 0 2 4 1 2 b 0 0 4
 

 

Sample Output
Case 1: 1 1 Case 2: 2 1 1 0

 

 //

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=80000;
struct Node
{
    int left,right;
    int l1,l2,r1,r2;
    int num;//010个数
};
Node tree[maxn*4];
char str[maxn];
int a[maxn];
void out(int id)
{
    cout<<id<<".."<<tree[id].left<<".."<<tree[id].right<<".."<<tree[id].l1<<".."<<tree[id].l2<<".."<<tree[id].r2<<".."<<tree[id].r1<<".."<<tree[id].num<<endl;
}
void merge(int id)
{
    if(tree[id<<1].r2==-1&&tree[(id<<1)|1].l2==-1)
    {
        tree[id].l1=tree[id].r2=tree[id<<1].l1;
        tree[id].l2=tree[id].r1=tree[(id<<1)|1].r1;
        tree[id].num=tree[id<<1].num+tree[(id<<1)|1].num;
    }
    else if(tree[id<<1].r2==-1&&tree[(id<<1)|1].l2!=-1)
    {
        tree[id].l1=tree[id<<1].l1;
        tree[id].l2=tree[(id<<1)|1].l1;
        tree[id].r1=tree[(id<<1)|1].r1;
        tree[id].r2=tree[(id<<1)|1].r2;
        tree[id].num=tree[id<<1].num+tree[(id<<1)|1].num;
        if(tree[id<<1].r1==0&&tree[(id<<1)|1].l1==1&&tree[(id<<1)|1].l2==0)
            tree[id].num++;
    }
    else if(tree[id<<1].r2!=-1&&tree[(id<<1)|1].l2==-1)
    {
        tree[id].l1=tree[id<<1].l1;
        tree[id].l2=tree[id<<1].l2;
        tree[id].r1=tree[(id<<1)|1].r1;
        tree[id].r2=tree[id<<1].r1;
        tree[id].num=tree[id<<1].num+tree[(id<<1)|1].num;
        if(tree[id<<1].r2==0&&tree[id<<1].r1==1&&tree[(id<<1)|1].l1==0)
            tree[id].num++;
    }
    else
    {
        tree[id].l1=tree[id<<1].l1;
        tree[id].l2=tree[id<<1].l2;
        tree[id].r1=tree[(id<<1)|1].r1;
        tree[id].r2=tree[(id<<1)|1].r2;
        tree[id].num=tree[id<<1].num+tree[(id<<1)|1].num;
        if(tree[id<<1].r2==0&&tree[id<<1].r1==1&&tree[(id<<1)|1].l1==0)
            tree[id].num++;
        if(tree[id<<1].r1==0&&tree[(id<<1)|1].l1==1&&tree[(id<<1)|1].l2==0)
            tree[id].num++;
    }
}
void buildtree(int id,int l,int r)
{
    tree[id].num=0;
    tree[id].left=l,tree[id].right=r;
    if(l==r)
    {
        tree[id].l1=tree[id].r1=a[l];
        tree[id].l2=tree[id].r2=-1;
    }
    else
    {
        int mid=(l+r)>>1;
        buildtree(id<<1,l,mid);
        buildtree((id<<1)|1,mid+1,r);
        merge(id);
    }
}
void update(int id,int p,int val)
{
    if(tree[id].left==tree[id].right)
    {
        tree[id].l1=tree[id].r1=val;
        return ;
    }
    int mid=(tree[id].left+tree[id].right)>>1;
    if(p<=mid) update(id<<1,p,val);
    else update((id<<1)|1,p,val);
    merge(id);
}
int query(int id,int l,int r)
{
    if(tree[id].left>=l&&tree[id].right<=r)
    {
        return tree[id].num;
    }
    int mid=(tree[id].left+tree[id].right)>>1;
    if(r<=mid) return query(id<<1,l,r);
    else if(l>=mid+1) return query((id<<1)|1,l,r);
    else
    {
        int cnt=0;
        if(l<=mid-1)
        if(tree[id<<1].r2==0&&tree[id<<1].r1==1&&tree[(id<<1)|1].l1==0)
            cnt++;
        if(r>=mid+2)
        if(tree[id<<1].r1==0&&tree[(id<<1)|1].l1==1&&tree[(id<<1)|1].l2==0)
            cnt++;
        return query(id<<1,l,mid)+query((id<<1)|1,mid+1,r)+cnt;
    }
}
int main()
{
    int ci,pl=1;scanf("%d",&ci);
    while(ci--)
    {
        int n,q;scanf("%d%d",&n,&q);
        scanf("%s",str);
        for(int i=1;i<=n;i++)
        {
            a[i]=str[i-1]=='b';
        }
        buildtree(1,1,n);
        printf("Case %d:\n",pl++);
        while(q--)
        {
            int flag;scanf("%d",&flag);
            if(!flag)
            {
                int l,r;scanf("%d%d",&l,&r);l++,r++;
                int cnt=query(1,l,r);
                printf("%d\n",cnt);
            }
            else
            {
                int idx;scanf("%d%s",&idx,str);idx++;
                update(1,idx,str[0]=='b');
            }
        }
    }
    return 0;
}
/*
1
10 100
wbwbwbwbwb
0 0 3
*/

抱歉!评论已关闭.