现在的位置: 首页 > 综合 > 正文

hdu 3434 给你含有n个数的序列,每次你可以选一个子序列将上面所有的数字加1或者减1,目标是把所有数字变成相同的,问最少步数,和那个相同的数字有多少种可能

2013年07月29日 ⁄ 综合 ⁄ 共 1477字 ⁄ 字号 评论关闭

Problem Description
Given a sequence consists of N integers. Each time you can choose a continuous subsequence and add 1 or minus 1 to the numbers in the subsequence .You task is to make all the numbers the same with 
the least tries. You should calculate the number of the least tries 
you needed and the number of different final sequences with the least tries.
 

Input
In the first line there is an integer T, indicates the number of test cases.(T<=30)
In each case, the first line contain one integer N(1<=N<=10^6), 
the second line contain N integers and each integer in the sequence is between [1,10^9].
There may be some blank lines between each case.
 

Output
For each test case , output “Case d: x y “ where d is the case number 
counted from one, x is the number of the least tries you need and y 
is the number of different final sequences with the least tries.
 

Sample Input
2 2 2 4 6 1 1 1 2 2 2
 

Sample Output
Case 1: 2 3 Case 2: 1 2
Hint
In sample 1, we can add 1 twice at index 1 to get {4,4},or minus 1 twice at index 2 to get {2,2}, or we can add 1 once at index 1 and minus 1 once at index 2 to get {3,3}. So there are three different final sequences.

//

//此题先要确定最优值范围在a[0]与a[n]之间所有值,所以有Max-Min+1个,任取一个最优值,第一个
//这样,可以得到最大上升偏移量,和最大下降偏移量,去其最大的就是最少要移动的次数 

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int A[1000005];
int main() {
    int cas,r=1;
    scanf("%d",&cas);
    while(cas--){
        int N;
        scanf("%d",&N);
        for(int i=0;i<N;i++)
            scanf("%d",&A[i]);
        long long a=0,b=0;
        for(int i=1;i<N;i++)
        {
            if (A[i]-A[i-1]>0) a+=A[i]-A[i-1];
            else b-=A[i]-A[i-1];
        }
        int Max = max(A[0],A[N-1]), Min = min(A[0],A[N-1]);
        printf("Case %d: %I64d %I64d\n",r++,(a>b?a:b),Max-Min+1);
    }
}

抱歉!评论已关闭.