现在的位置: 首页 > 综合 > 正文

hdu 3449 Consumer 条件背包 有钱w,给出n种选择,每种选择有m[i]个物品,但必须先买盒子,价格p[i],求买的物品的最大价值

2013年01月23日 ⁄ 综合 ⁄ 共 1726字 ⁄ 字号 评论关闭
Problem Description
FJ is going to do some shopping, and before that, he needs some boxes to carry the different kinds of stuff he is going to buy. Each box is assigned to carry some specific kinds of stuff (that is to say, if he is going to buy one
of these stuff, he has to buy the box beforehand). Each kind of stuff has its own value. Now FJ only has an amount of W dollars for shopping, he intends to get the highest value with the money.
 

 

Input
The first line will contain two integers, n (the number of boxes 1 <= n <= 50), w (the amount of money FJ has, 1 <= w <= 100000) Then n lines follow. Each line contains the following number pi (the price of the ith box 1<=pi<=1000),
mi (1<=mi<=10 the number goods ith box can carry), and mi pairs of numbers, the price cj (1<=cj<=100), the value vj(1<=vj<=1000000)
 

 

Output
For each test case, output the maximum value FJ can get
 

 

Sample Input
3 800 300 2 30 50 25 80 600 1 50 130 400 3 40 70 30 40 35 60
 

 

Sample Output
210

 

 //

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=110000;
int boxn,money;//箱子数量,总钱数
int dp[maxn],f[maxn];//加上当前最大价值,前i行最大价值
int boxv[60];//箱子花费
int num[60];//箱子带物品个数
int c[60][20],v[60][20];//物品花费,价值
int main()
{
    while(scanf("%d%d",&boxn,&money)==2)
    {
        for(int i=1;i<=boxn;i++)
        {
            scanf("%d%d",&boxv[i],&num[i]);
            for(int j=1;j<=num[i];j++) scanf("%d%d",&c[i][j],&v[i][j]);
        }
        memset(f,0,sizeof(f));
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=boxn;i++)
        {
            for(int j=boxv[i];j<=money;j++) dp[j]=f[j-boxv[i]];//加上当前箱子的花费
            for(int j=1;j<=num[i];j++)
            {
                for(int k=money;k>=c[i][j]+boxv[i];k--)
                {
                    dp[k]=max(dp[k],dp[k-c[i][j]]+v[i][j]);
                }
            }
            for(int j=boxv[i];j<=money;j++) f[j]=max(f[j],dp[j]);
        }
        printf("%d\n",f[money]);
    }
    return 0;
}

抱歉!评论已关闭.