现在的位置: 首页 > 综合 > 正文

poj 1980 Unit Fraction Partition 分数划分,将分数分解为n个真分数之和,分母乘积不超过a

2013年12月08日 ⁄ 综合 ⁄ 共 2017字 ⁄ 字号 评论关闭
Unit Fraction Partition
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 2797   Accepted: 1077

Description

A fraction whose numerator is 1 and whose denominator is a positive integer is called a unit fraction. A representation of a positive rational number p/q as the sum of finitely many unit fractions is called a partition of p/q into unit fractions. For example, 1/2 + 1/6 is a partition of 2/3 into unit fractions. The difference in the order of addition is disregarded. For example, we do not distinguish 1/6 + 1/2 from 1/2 + 1/6. 

For given four positive integers p, q, a, and n, count the number of partitions of p/q into unit fractions satisfying the following two conditions. 

The partition is the sum of at most n many unit fractions. 
The product of the denominators of the unit fractions in the partition is less than or equal to a. 
For example, if (p,q,a,n) = (2,3,120,3), you should report 4 since 

enumerates all of the valid partitions. 

Input

The input is a sequence of at most 200 data sets followed by a terminator. 

A data set is a line containing four positive integers p, q, a, and n satisfying p,q <= 800, a <= 12000 and n <= 7. The integers are separated by a space. 

The terminator is composed of just one line which contains four zeros separated by a space. It is not a part of the input data but a mark for the end of the input. 

Output

The output should be composed of lines each of which contains a single integer. No other characters should appear in the output. 

The output integer corresponding to a data set p, q, a, n should be the number of all partitions of p/q into at most n many unit fractions such that the product of the denominators of the unit fractions is less than or equal to a. 

Sample Input

2 3 120 3
2 3 300 3
2 3 299 3
2 3 12 3
2 3 12000 7
54 795 12000 7
2 3 300 1
2 1 200 5
2 4 54 2
0 0 0 0

Sample Output

4
7
6
2
42
1
0
9
3



#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
int cnt;
int p,q,a,n;
void dfs(int t,int pl,int tp,int tq,int fac)
{
    if(fac>a) return ;
    if(p*tq==q*tp&&tq!=0) {cnt++;return ;}
    if(pl>=n) return ;
    if(p*tq<q*tp) return ;
    //用t 1/t+tp/tq=(tq+t*tp)/(t*tq);
    int x,y;
    if(tq){
    x=tq+t*tp,y=t*tq;
    }
    else x=1,y=t;
    if(fac*t<=a) dfs(t,pl+1,x,y,fac*t);
    //不用t  fac*(t+1)<=a 剪枝很重要
    if(t+1<=a&&fac*(t+1)<=a) dfs(t+1,pl,tp,tq,fac);
}
int main()
{
    while(scanf("%d%d%d%d",&p,&q,&a,&n)==4&&q)
    {
        cnt=0;
        dfs(1,0,0,0,1);
        printf("%d/n",cnt);
    }
    return 0;
}

抱歉!评论已关闭.