现在的位置: 首页 > 综合 > 正文

poj 2002 Squares 判断一些点能组成多少个正方形 二分查找

2013年06月30日 ⁄ 综合 ⁄ 共 2040字 ⁄ 字号 评论关闭
Squares
Time Limit: 3500MS   Memory Limit: 65536K
Total Submissions: 8864   Accepted: 3088

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however, as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input

4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0

Sample Output

1
6
1
#include <iostream>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <cstdio>
using namespace std;
struct node
{
    int x, y;
} p[1001];
bool op(const struct node &xx, const struct node &yy)
{
    if (xx.x == yy.x)
        return xx.y < yy.y;
    else
        return xx.x < yy.x;
}
int main()
{
    int points;
    while (scanf("%d", &points), points)
    {
        int sum = 0;
        for (int i = 0; i < points; ++i)
            scanf("%d%d", &p[i].x, &p[i].y);
        sort(p, p + points, op);
        for (int i = 0; i < points; ++i)
        {
            for (int j = i + 1; j < points; ++j)
            {
                //已知正方形两点的坐标(是正方形的一边),求另两点
                //p[i]--p1,p[j]--p0
                node p0, p1;
                p0.x = p[i].x + p[j].y - p[i].y;
                p0.y = p[i].y + p[i].x - p[j].x;
                p1.x = p[j].x + p[j].y - p[i].y;
                p1.y = p[j].y + p[i].x - p[j].x;
                if (!binary_search(p, p+points, p0, op))
                    continue;
                if (!binary_search(p, p+points, p1, op))
                    continue;
                sum++;
            }
        }
        printf("%d/n", sum / 2);//最后要除以2
    }
    return 0;
}

抱歉!评论已关闭.