现在的位置: 首页 > 综合 > 正文

hdu 3625 Examining the Rooms 第一类斯特林数

2013年12月15日 ⁄ 综合 ⁄ 共 2961字 ⁄ 字号 评论关闭

Examining the Rooms

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 182    Accepted Submission(s): 89

Problem Description
A murder happened in the hotel. As the best detective in the town, you should examine all the N rooms of the hotel immediately. However, all the doors of the rooms are locked, and the keys are just locked in the rooms, what a trap! You know that there is exactly one key in each room, and all the possible distributions are of equal possibility. For example, if N = 3, there are 6 possible distributions, the possibility of each is 1/6. For convenience, we number the rooms from 1 to N, and the key for Room 1 is numbered Key 1, the key for Room 2 is Key 2, etc.
To examine all the rooms, you have to destroy some doors by force. But you don’t want to destroy too many, so you take the following strategy: At first, you have no keys in hand, so you randomly destroy a locked door, get into the room, examine it and fetch the key in it. Then maybe you can open another room with the new key, examine it and get the second key. Repeat this until you can’t open any new rooms. If there are still rooms un-examined, you have to randomly pick another unopened door to destroy by force, then repeat the procedure above, until all the rooms are examined.
Now you are only allowed to destroy at most K doors by force. What’s more, there lives a Very Important Person in Room 1. You are not allowed to destroy the doors of Room 1, that is, the only way to examine Room 1 is opening it with the corresponding key. You want to know what is the possibility of that you can examine all the rooms finally.
 

 

Input
The first line of the input contains an integer T (T ≤ 200), indicating the number of test cases. Then T cases follow. Each case contains a line with two numbers N and K. (1 < N ≤ 20, 1 ≤ K < N)
 

 

Output
Output one line for each case, indicating the corresponding possibility. Four digits after decimal point are preserved by rounding.
 

 

Sample Input
3 3 1 3 2 4 2
 

 

Sample Output
0.3333 0.6667 0.6250
Sample Explanation When N = 3, there are 6 possible distributions of keys: Room 1 Room 2 Room 3 Destroy Times #1 Key 1 Key 2 Key 3 Impossible #2 Key 1 Key 3 Key 2 Impossible #3 Key 2 Key 1 Key 3 Two #4 Key 3 Key 2 Key 1 Two #5 Key 2 Key 3 Key 1 One #6 Key 3 Key 1 Key 2 One In the first two distributions, because Key 1 is locked in Room 1 itself and you can’t destroy Room 1, it is impossible to open Room 1. In the third and forth distributions, you have to destroy Room 2 and 3 both. In the last two distributions, you only need to destroy one of Room 2 or Room
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int N=21;//(0--N-1)
long long fac[N]={1,1};
long long  stir[N][N];//第一类stirling numbers  给出恰包含 m 个圈的 n 个元素 的排列数目
//stir[i][j] = (i-1) * stir[i-1][j] + stir[i-1][j-1];
void calc_stir(long long stir[][N])//计算第一类斯特林数
{
    memset(stir,0,sizeof(stir));
    stir[0][1]=1;//important
    for(int i=1;i<N;i++)stir[i][0]=0;
    for(int i=1;i<N;i++)
    {
        for(int j=1;j<=i;j++)
        {
            if(i==j) stir[i][j]=1;//important
            else stir[i][j]=(i-1)*stir[i-1][j]+stir[i-1][j-1];
        }
    }
}
int main()
{
    for(int i=2;i<21;i++) fac[i]=i*fac[i-1];
    calc_stir(stir);
    int ci;scanf("%d",&ci);
    while(ci--)
    {
        int n,k;scanf("%d%d",&n,&k);
        long long cnt=0;
        for(int i=1;i<=k;i++) cnt+=stir[n][i]-stir[n-1][i-1];//表示去掉1自己成环的情况
        printf("%.4lf/n",1.0*cnt/fac[n]);
    }
    return 0;
}

抱歉!评论已关闭.