现在的位置: 首页 > 综合 > 正文

2478 Farey Sequence 求欧拉函数,利用递推公式

2013年11月13日 ⁄ 综合 ⁄ 共 1704字 ⁄ 字号 评论关闭
Farey Sequence
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 6416   Accepted: 2316

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5
9

Source

 

 

 

 

 

 

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
int oula[1000010];
long long sum[1000010];
int is[1000010],prime[1000010],pl;
void getprime()
{
    for(int i=2;i<1000010;i++)
    {
        if(is[i]==0) prime[pl++]=i;//0表示素数
        for(int j=0;j<pl&&i*prime[j]<1000010;j++)
        {
            is[i*prime[j]]=1;
            if(i%prime[j]==0) break;
        }
    }
}
int main()
{
    getprime();
    //欧拉函数递推性质:如果素数p|x:如果p*p|x,则oula[x]=oula[x/p]*p;否则oula[x]=oula[x/p]*(p-1)
    for(int i=2;i<=1000000;i++)//此题中不用考虑1
    {
        if(is[i]==0) oula[i]=i-1;
        else
        {
            double k=sqrt(0.5+i);
            for(int j=0;j<pl&&prime[j]<=k;j++)
            {
                if(i%prime[j]==0)
                {
                    if(i%(prime[j]*prime[j])==0) oula[i]=oula[i/prime[j]]*prime[j];
                    else oula[i]=oula[i/prime[j]]*(prime[j]-1);
                    break;
                }
            }
        }
        sum[i]=oula[i]+sum[i-1];
    }
    int n;
    while(scanf("%d",&n)==1&&n)
    {
        cout<<sum[n]<<endl;
    }
    return 0;
}

 

抱歉!评论已关闭.