现在的位置: 首页 > 综合 > 正文

1171 Big Event in HDU hdu 将物品分成接近的两份转换成0-1或多重背包问题

2013年02月14日 ⁄ 综合 ⁄ 共 1957字 ⁄ 字号 评论关闭

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5007    Accepted Submission(s): 1546

Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

 

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

 

Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

 

Sample Input
2 10 1 20 1 3 10 1 20 2 30 1 -1
 

 

Sample Output
20 10 40 40
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
int f[250005],n;
int a[250005],w[250005],cnt,sum;
int main()
{
    while(scanf("%d",&n)==1&&n>=0)
    {
        cnt=0;sum=0;
        for(int i=0;i<n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            while(y--)
            {
                a[cnt]=x;
                w[cnt++]=x;
                sum+=x;
            }
        }
        memset(f,0,sizeof(f)); 
        for(int i=0;i<cnt;i++)
        {
            for(int j=sum/2;j>=a[i];j--)
            {
                f[j]= max(f[j],f[j-a[i]]+w[i]);
            }
        }
        int ans1=f[sum/2],ans2=sum-ans1;
        if(ans1<ans2) swap(ans1,ans2);
        printf("%d %d/n",ans1,ans2);
    }
    return 0;
}               
           

抱歉!评论已关闭.