现在的位置: 首页 > 综合 > 正文

2407 Relatives 欧拉函数

2013年01月27日 ⁄ 综合 ⁄ 共 901字 ⁄ 字号 评论关闭
Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 5921   Accepted: 2606

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4
#include<stdio.h>
int main()
{
    int n,k;
    while(scanf("%d",&n)&&n)
    {
        int b=n;k=2;
        int res=n;
        while(k<=b)
        {
            if(b%k==0)
            {
                res-=res/k;
                b/=k;
            }
            while(b%k==0) b/=k;
            if(b==1) break;
            k++;
        }
        if(b==n) {printf("%d/n",n-1);continue;}
        if(b>1&&b<n) res-=res/k;
  printf("%d/n",res);
    }
    return 0;
}

抱歉!评论已关闭.