现在的位置: 首页 > 综合 > 正文

1184: The Circumference of the Circle 三角形外接圆半径 周长

2013年04月11日 ⁄ 综合 ⁄ 共 1693字 ⁄ 字号 评论关闭
文章目录

1184: The Circumference of the Circle


Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
1s 8192K 388 264 Standard

To calculate the circumference of a circle seems to be an easy task - provided you know its diameter. But what if you don't?

You are given the cartesian coordinates of three non-collinear points in the plane.
Your job is to calculate the circumference of the unique circle that intersects all three points.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing six real numbers x1,y1, x2,y2,x3,y3, representing the coordinates of the three points. The diameter of the circle determined by the three points will never exceed a million. Input is terminated by end of file.

Output Specification

For each test case, print one line containing one real number telling the circumference of the circle determined by the three points. The circumference is to be printed accurately rounded to two decimals. The value of pi is approximately 3.141592653589793.

Sample Input

0.0 -0.5 0.5 0.0 0.0 0.5
0.0 0.0 0.0 1.0 1.0 1.0
5.0 5.0 5.0 7.0 4.0 6.0
0.0 0.0 -1.0 7.0 7.0 7.0
50.0 50.0 50.0 70.0 40.0 60.0
0.0 0.0 10.0 0.0 20.0 1.0
0.0 -500000.0 500000.0 0.0 0.0 500000.0

Sample Output

3.14
4.44
6.28
31.42
62.83
632.24
3141592.65
#include<iostream>
#include<math.h>
using namespace std;
const double pi= 3.141592653589793;
double bc(double x1,double y1,double x2,double y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
    double x1,y1,x2,y2,x3,y3;
    while(cin>>x1>>y1>>x2>>y2>>x3>>y3)
    {
        double a=bc(x1,y1,x2,y2),b=bc(x1,y1,x3,y3),c=bc(x2,y2,x3,y3);
        double s=(a+b+c)/2;
        double area=sqrt(s*(s-a)*(s-b)*(s-c));
        double r=a*b*c/area/4;
        printf("%.2lf/n",2*pi*r);
    }
    return 0;
}
/*外圆半径   =     abc   /   (4*面积)
  内圆半径   =       2   *   面积   /   周长
  计算出三个边的长度,a,b,c
  那么
  周长   =   a   +   b   +   c   =   2   *   s
  面积   =   sqrt(   s*(s-a)*(s-b)*(s-c)   )
  */

抱歉!评论已关闭.