现在的位置: 首页 > 综合 > 正文

1176: Square Coins

2013年03月26日 ⁄ 综合 ⁄ 共 1284字 ⁄ 字号 评论关闭
文章目录

1176: Square Coins


Result TIME Limit MEMORY Limit Run Times AC Times JUDGE
3s 8192K 479 309 Standard
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=172), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.

There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

 


This problem is used for contest: 72 

 

#include<stdio.h>
int coin[17]={1,4,9,16,25,36,49,64,81,100,121,144,169,196,225,256,289};
int main()
{
    int a[100000]={0};
    a[0]=1;
    int i,j;
    for(i=0;i<17;i++)
    {
        for(j=coin[i];j<100000;j++)
        {
            a[j]+=a[j-coin[i]];
        }
    }
    int n;
    while(scanf("%d",&n)==1&&n)
    {
        printf("%d/n",a[n]);
    }
    return 0;
}

 

抱歉!评论已关闭.