现在的位置: 首页 > 综合 > 正文

JOJ1534: Sticks(麻烦的剪枝)

2013年12月14日 ⁄ 综合 ⁄ 共 1584字 ⁄ 字号 评论关闭

 


Status In/Out TIME Limit MEMORY Limit Submit Times Solved Users JUDGE TYPE
stdin/stdout 3s 8192K 942 143 Standard

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

Input

The input file contains blocks of 2 lines. The first line contains the number of sticks parts after cutting. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

Output

The output file contains the smallest possible length of original sticks, one per line.

Sample Input

 

9
5 2 1 5 2 1 5 2 1
4
1 2 3 4
0

Sample Output

 

6
5

 

 


This problem is used for contest: 119  150 

 

#include<stdio.h>
#include<algorithm>
using namespace std;
bool visit[100],flag;
int a[100],n,sum,beg;
bool cmp(int a,int b)
{
 return a>b;
}
void dfs(int depth,int sheng)
{
 if(depth==n&&sheng==0)
 {
  flag=true;
  return;
 }
 if(flag) return;
 if(sheng==0) sheng=beg;
 for(int i=0;i<n&&!flag;i++)
 if(!visit[i]&&a[i]<=sheng)
 {
  visit[i]=true;
  dfs(depth+1,sheng-a[i]);
  visit[i]=false;
  if(sheng==beg||a[i]==sheng||flag) break;//这个剪枝让我很无语
 }
}
int main()
{
 //freopen("in.txt","r",stdin);
 //freopen("out.txt","w",stdout);
 int i;
 while((scanf("%d",&n),n)!=0)
 {
  sum=0;
  flag=false;
  for(i=0;i<n;i++)  
  {
   scanf("%d",&a[i]);
   visit[i]=false;
   sum+=a[i];
  }
        sort(a,a+n,cmp);
  beg=a[0]-1;
  while(beg<=sum)
  {
   beg++;
   if(sum%beg!=0) continue;
   dfs(0,beg);
   if(flag)
   {
    printf("%d/n",beg);
    break;
   }
  }  
 }
 return 0;
}

 

抱歉!评论已关闭.