现在的位置: 首页 > 综合 > 正文

HDU 4104

2013年12月10日 ⁄ 综合 ⁄ 共 1592字 ⁄ 字号 评论关闭

 

Discount

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 89    Accepted Submission(s): 70

Problem Description


All the shops use discount to attract customers, but some shops doesn’t give direct discount on their goods, instead, they give discount only when you bought more than a certain amount of goods. Assume a shop offers a 20% off if your bill is more than 100 yuan,
and with more than 500 yuan, you can get a 40% off. After you have chosen a good of 400 yuan, the best suggestion for you is to take something else to reach 500 yuan and get the 40% off.
For the customers’ convenience, the shops often offer some low-price and useful items just for reaching such a condition. But there are still many customers complain that they can’t reach exactly the budget they want. So, the manager wants to know, with the
items they offer, what is the minimum budget that cannot be reached. In addition, although the items are very useful, no one wants to buy the same thing twice.
 

Input
The input consists several testcases.
The first line contains one integer N (1 <= N <= 1000), the number of items available.
The second line contains N integers Pi (1 <= Pi <= 10000), represent the ith item’s price.

 

Output
Print one integer, the minimum budget that cannot be reached.
 

Sample Input
4 1 2 3 4
 

Sample Output
11
 

Source
 
刚开始楞没想明白是怎么一回事。
后来受到了梦翅大神的颠簸,瞬间就明白了。。
这个题就是一个归纳法。
如果1...x能够被标示,那么x+1如果不能被表示的话,除非没有x+1这个数。
 
我的代码:
#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;

int a[1005],sum[1005];

int main()
{
	int n,i;
	while(scanf("%d",&n)!=EOF)
	{
		memset(sum,0,sizeof(sum));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		sort(a+1,a+1+n);
		for(i=1;i<=n;i++)
			sum[i]=sum[i-1]+a[i];
		for(i=1;i<=n;i++)
		{
			if(a[i]>sum[i-1]+1)
				break;
		}
		printf("%d\n",sum[i-1]+1);
	}
	return 0;
}

抱歉!评论已关闭.