现在的位置: 首页 > 综合 > 正文

HDU 1556(树状数组-区间修改,查询点)

2013年11月05日 ⁄ 综合 ⁄ 共 1432字 ⁄ 字号 评论关闭

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6752    Accepted Submission(s): 3534


Problem Description
N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗?
 


Input
每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。
当N = 0,输入结束。
 


Output
每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。
 


Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 


Sample Output
1 1 1 3 2 1
 


Author
8600
 


Source
 

线段树写过,不过还是树状数组好写啊。。

/****************************************************
* author:crazy_石头
* Pro:HDU1556
* algorithm:树状数组
* Time:32ms
* Judge Status:Accepted
*******************************************************/
#pragma comment(linker, "/STACK:102400000,102400000")
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <queue>
#include <vector>
#include <algorithm>
#include <cmath>

using namespace std;

#define rep(i,h,n) for(int i=(h);i<=(n);i++)
#define ms(a,b) memset((a),(b),sizeof(a))
#define eps 1e-8
#define INF 1<<29
#define LL __int64
const int maxn=200000+5;

int C[maxn],n,a[maxn];
inline int lowbit(int x)
{
    return x&(-x);
}

inline void update(int x,int num)
{
    while(x<=n)
    {
        C[x]+=num;
        x+=lowbit(x);
    }
}

inline int getsum(int x)
{
    int res=0;
    while(x>0)
    {
        res+=C[x];
        x-=lowbit(x);
    }
    return res;
}

int main()
{
    while(cin>>n&&n)
    {
        ms(C,0);
        int l,r;
        rep(i,1,n)
        {
            cin>>l>>r;
            update(l,1);
            update(r+1,-1);
        }
        rep(i,1,n)
        i==1?printf("%d",getsum(i)):printf(" %d",getsum(i));
        cout<<endl;
    }
    return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.