现在的位置: 首页 > 综合 > 正文

UVa 10271 – Chopsticks dp

2013年11月17日 ⁄ 综合 ⁄ 共 2259字 ⁄ 字号 评论关闭

Problem C
Chopsticks
Input:
 Standard Input
Output: Standard Output

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through
the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C),
(A-B)2 is called the 'badness' of the set.

It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his
little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of
all the sets is minimized.

Input

The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number
of chopsticks. There are N positive integers Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).

Output

For each test case in the input, print a line containing the minimal total badness of all the sets.

Sample Input

1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

Sample Output

23

Note

For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
__________________________________________________________________________________________
Rujia Liu

-------------------

囧,将数组从大到小排序。

f[i][j]表示前j个筷子组成前i组筷子的最小值

-----------------

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int a[5555];
int f[1111][5555];
int n,k;

bool cmp(int a,int b)
{
    return a>b;
}

int main()
{
    int T;
    scanf("%d",&T);
    while (T--)
    {
        memset(a,0,sizeof(a));
        memset(f,0,sizeof(f));
        scanf("%d%d",&k,&n);
        k+=8;
        for (int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        sort(a+1,a+n+1,cmp);
        for (int i=1;i<=k;i++)
        {
            f[i][i*3]=f[i-1][i*3-2]+(a[i*3-1]-a[i*3])*(a[i*3-1]-a[i*3]);
            for (int j=i*3+1;j<=n;j++)
            {
                f[i][j]=min( f[i][j-1], f[i-1][j-2]+(a[j-1]-a[j])*(a[j-1]-a[j]) );
            }
        }
        printf("%d\n",f[k][n]);
    }
    return 0;
}

抱歉!评论已关闭.