现在的位置: 首页 > 综合 > 正文

【PAT】1043. Is It a Binary Search Tree (25)

2013年11月06日 ⁄ 综合 ⁄ 共 3076字 ⁄ 字号 评论关闭

题目链接:http://pat.zju.edu.cn/contests/pat-a-practise/1043

题目描述:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line "YES" if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or "NO" if not. Then if the answer is "YES", print in the next line the postorder traversal sequence of that tree. All
the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

分析:

(1)构建二叉查找树

(2)对二叉查找树的前序遍历,后序遍历

(3)对镜像二叉查找树的前序遍历,后序遍历

参考代码:

#include<iostream>
#include<vector>
#include<string.h> //memset
using namespace std;

vector<int> vec_LR;
vector<int> vec_RL;
vector<int> post_LR;
vector<int> post_RL;

struct Node
{
	Node *left;
	Node *right;
	int value;
	Node():left(NULL),right(NULL){}
	Node(int v):left(NULL),right(NULL),value(v){}
};

//要特别注意函数的参数为Node * &root, 
//如果是Node * root , 最终root依然是NULL
void insert(Node* &root, int v)
{
	if(root == NULL)
	{
		root = new Node(v);
		return ;
	}
	if(root->value > v)
	{
		insert(root->left,v);
	}
	else if(root->value <= v)
	{
		insert(root->right,v);
	}
}
//对二叉查找树的前序遍历
void PreOrder_LR(Node *root)
{
	if(root != NULL)
	{
	    vec_LR.push_back(root->value);
		PreOrder_LR(root->left);
		PreOrder_LR(root->right);
	}
}
//对镜像二叉查找树的前序遍历
void PreOrder_RL(Node *root)
{
	if(root != NULL)
	{
		vec_RL.push_back(root->value);
		PreOrder_RL(root->right);
		PreOrder_RL(root->left);
	}
}
//对二叉查找树的后序遍历
void PostOrder_LR(Node *root)
{
	if(root != NULL)
	{
		PostOrder_LR(root->left);
		PostOrder_LR(root->right);
		post_LR.push_back(root->value);
	}
}
//对镜像二叉查找树的后序遍历
void PostOrder_RL(Node *root)
{
	if(root != NULL)
	{
		PostOrder_RL(root->right);
		PostOrder_RL(root->left);
		post_RL.push_back(root->value);
	}
}

int main()
{
	int n;
	while(cin>>n)
	{
		int i;
		int *preorder = new int[n];
		Node *root = NULL;
		//构建线索二叉树
		for(i=0; i<n; i++)
		{
			cin>>preorder[i];
			insert(root,preorder[i]);
		}
		//进行前序遍历
		PreOrder_LR(root);
		bool flag = true;
		bool is_mirror = false;
		//判断是否是二叉查找树的前序遍历
		for(i=0; i<n; i++)
		{
			if(preorder[i] != vec_LR[i]){ 
				flag = false;
				break;
			}
		}
		//如果不是二叉查找树的前序遍历,
		//就判断是否是镜像二叉查找树的前序遍历
		if(!flag)
		{
			PreOrder_RL(root);
			flag = true;
			for(i=0; i<n; i++)
				if(preorder[i] != vec_RL[i]){
					flag = false;
					break;
			}
			if(flag) 
				is_mirror = true;
		}
		if(!flag){
			cout<<"NO"<<endl;
		}else{
			cout<<"YES"<<endl;
			if(is_mirror){
				PostOrder_RL(root);
				for(i=0; i<post_RL.size(); i++)
				{
					cout<<post_RL[i];
					if(i != post_RL.size() - 1)
						cout<<" ";
				}
			}else{
				PostOrder_LR(root);
				for(i=0; i<post_LR.size(); i++)
				{
					cout<<post_LR[i];
					if(i != post_LR.size() - 1)
						cout<<" ";
				}
			}
			cout<<endl;
		}
        post_LR.clear();
		post_RL.clear();
		vec_LR.clear();
		vec_RL.clear();
	}
	return 0;
}

【上篇】
【下篇】

抱歉!评论已关闭.