现在的位置: 首页 > 综合 > 正文

Java程序练习-Peter’s smokes

2013年05月30日 ⁄ 综合 ⁄ 共 582字 ⁄ 字号 评论关闭

 描述
Peter has n cigarettes. He smokes them one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
How many cigarettes can Peter have?

输入
Input is a sequence of lines. Each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
4 3
10 3
100 5
样例输出
5
14
124
参考代码

import java.util.*;
public class Main {
	public static void main(String[] args) {
		Scanner cin = new Scanner(System.in);
		while(cin.hasNextInt()){
			int n,k,c,t;
			n = cin.nextInt();
			k = cin.nextInt();
			c = 0;
			t = 0;
			while(n > 0){
				c += n;
				t += n;
				n = t / k;
				t %= k;
			}
			System.out.println(c);
		}
	}
}

 

抱歉!评论已关闭.