现在的位置: 首页 > 综合 > 正文

一道水题Q2004

2013年12月19日 ⁄ 综合 ⁄ 共 643字 ⁄ 字号 评论关闭
Problem Description
输入一个百分制的成绩t,将其转换成对应的等级,具体转换规则如下:
90~100为A;
80~89为B;
70~79为C;
60~69为D;
0~59为E;
 


Input
输入数据有多组,每组占一行,由一个整数组成。
 


Output
对于每组输入数据,输出一行。如果输入数据不在0~100范围内,请输出一行:“Score is error!”。
 


Sample Input
56 67 100 123
 


Sample Output
E D A Score is error!

import java.util.Scanner;


public class Q2004 {
	public static void main(String[] args){
		
		Scanner s = new Scanner(System.in);
		while(s.hasNext()){
			double d = s.nextDouble();
			if(d>=90 && d<=100) System.out.println("A");
			else if(d>=80 && d<90) System.out.println("B");
			else if(d>=70 && d<80) System.out.println("C");
			else if(d>=60 && d<70) System.out.println("D");
			else if(d>=0 && d<60) System.out.println("E");
			else System.out.println("Score is error!");
			
			}
		s.close();
		}
		
	}

抱歉!评论已关闭.