现在的位置: 首页 > 综合 > 正文

河南省第四届程序设计大赛–Substring

2013年02月13日 ⁄ 综合 ⁄ 共 1403字 ⁄ 字号 评论关闭

描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a 
tie, return the string that occurs earliest in input.
Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is 
find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入

The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 
characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').

输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input

样例输入
3                   
ABCABA
XYZ
XCVCX

样例输出
ABA
X

XCVCX

很一般的一道题,类似回文字串。但不同的是回文子串的意思是正着看和倒着看是相同的。比如ABCDBA的最长回文字串是A,但这道题的意思是,the reversal of the substring is also a substring of input。就是它的逆子串也存在在这个字符串中,如上例,结果应该是AB。这点很关键,读题一点要仔细,要不然就会想当然。就这么一点错误,可能你再检查N次也不知道哪里错了。

思路很简单:

1.

代码如下:

#include<iostream>
#include<cstdio>
#include<string>
#include<algorithm>
using namespace std;

int main()
{
	int ncase, i, j, maxlen;
	scanf("%d", &ncase);
	while(ncase--)
	{
		string str, tmp, res; //str原始数据,tmp倒置str,res相同子串
		cin>>str;
		tmp = str;
		reverse(tmp.begin(), tmp.end()); //倒置
		maxlen = 0;
		for(i = 0; i < str.size(); ++i)
		{
			for(j = 1; j <= str.size() - i; ++j) //j代表截取的长度
			{
				if(tmp.find(str.substr(i, j)) != string::npos) //如果截取匹配
				{
					if(j > maxlen)
					{
						maxlen = j; //长度更新
						res = str.substr(i, j); //最长子串
					}
				}
			}
		}
		cout<<res<<endl;
	}
	return 0;
}

抱歉!评论已关闭.