现在的位置: 首页 > 综合 > 正文

Cow Picnic poj

2013年12月08日 ⁄ 综合 ⁄ 共 1756字 ⁄ 字号 评论关闭
Cow Picnic
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 4689   Accepted: 1895

Description

The cows are having a picnic! Each of Farmer John's K (1 ≤ K ≤ 100) cows is grazing in one of N (1 ≤ N ≤ 1,000) pastures, conveniently numbered 1...N. The pastures are connected by M (1 ≤ M ≤
10,000) one-way paths (no path connects a pasture to itself).

The cows want to gather in the same pasture for their picnic, but (because of the one-way paths) some cows may only be able to get to some pastures. Help the cows out by figuring out how many pastures are reachable by all cows, and hence are possible picnic
locations.

Input

Line 1: Three space-separated integers, respectively: KN, and M 
Lines 2..K+1: Line i+1 contains a single integer (1..N) which is the number of the pasture in which cow i is grazing. 
Lines K+2..M+K+1: Each line contains two space-separated integers, respectively A and B (both 1..N and A != B), representing a one-way path from pasture A to pasture B.

Output

Line 1: The single integer that is the number of pastures that are reachable by all cows via the one-way paths.

Sample Input

2 4 4
2
3
1 2
1 4
2 3
3 4

Sample Output

2

Hint

The cows can meet in pastures 3 or 4.
简单的搜索问题!
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<vector>
using namespace std;
vector <int> way[10010];
int pasture[1010];
int num[1010];
int vis[1010];
void dfs(int n)//宽度搜索
{
     if(vis[n])  return ;
     num[n]++;//记录下每个节点被访问的次数
     vis[n]=1;//已被访问(防止进入死循环)
     if(way[n].size()==0) return ;
     else
     for(int i = 0;i<way[n].size();++i)
         dfs(way[n][i]);//宽度搜索
}
int main()
{
    int c_num,p_num,w_num;
    while(scanf("%d%d%d",&c_num,&p_num,&w_num)==3)
    {
        memset(num,0,sizeof(num));

        for(int i = 0;i<c_num;++i)
          scanf("%d",&pasture[i]);


        for(int i = 0;i<w_num;++i)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            way[a].push_back(b);
        }

        for(int i = 0;i<c_num;++i)
        {
            memset(vis,0,sizeof(vis));
            dfs(pasture[i]);//对每一头牛进行宽度搜索
        }

        int sum = 0;
        for(int i = 1;i<=p_num;++i)
         if(num[i]==c_num)//如果有某个节点被访问的次数与牛的头数相等,那么这个点一定满足条件
               sum++;

       printf("%d\n",sum);
    }
}

抱歉!评论已关闭.