现在的位置: 首页 > 综合 > 正文

Piggy-Bank

2013年10月26日 ⁄ 综合 ⁄ 共 2950字 ⁄ 字号 评论关闭

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6808    Accepted Submission(s): 3353


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes
all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to
be paid. 

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility
is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank
that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 

 


Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights
are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are
exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 


Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight
cannot be reached exactly, print a line "This is impossible.". 
 


Sample Input
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 


Sample Output
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.
比较典型的完全背包问题!!
将d[0]初始化为0
其他的都初始化为INF(因为求的是最小值,求最大值的话必须初始化为0)
要求恰好装满的话只有d[0]的初值有合理解0;
容量为零恰好装满的最优解自然为零,
其他初始化为正无穷(因为他求最小值,即不存在合理解);
#include<iostream>
#include<stdlib.h>
#include<math.h>
#include<stdio.h>
#include<algorithm>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<vector>
#define INF 1000000000
using namespace std;
struct coin
{
    int p;
    int w;
}c[520];
int d[10000];
int main()
{
    int t;
    scanf("%d",&t);
    for(int L = 0;L<t;++L)
    {
        for(int i = 1;i<10000;++i)
         d[i] = INF;
         d[0] = 0;
        int E,F;
        scanf("%d%d",&E,&F);
        int total = F - E;
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;++i)
        {
            scanf("%d%d",&c[i].p,&c[i].w);
        }
        
        for(int i=1;i<=n;++i)
         for(int j=c[i].w;j<=total;++j)
           {
               d[j] = min(d[j],d[j-c[i].w]+c[i].p);
           }
           
           if(d[total]==INF)
           printf("This is impossible.\n");
           else
           printf("The minimum amount of money in the piggy-bank is %d.\n",d[total]);
    }
    return 0;
}

抱歉!评论已关闭.