现在的位置: 首页 > 综合 > 正文

FatMouse and Cheese

2013年12月09日 ⁄ 综合 ⁄ 共 2227字 ⁄ 字号 评论关闭

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3207    Accepted Submission(s): 1260


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole.
Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run
at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks
of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

 


Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

 


Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 


Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 


Sample Output
37
 
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <string.h>
#include <stdlib.h>
#include <vector>
#define FOR(i,s,t) for(int i = (s);i<(t);++i)
using namespace std;
int grid[110][110];
int d[110][110];
int vis[110][110];
int dir[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
int n,k;
int dfs(int x,int y)//深度遍历
{
    if(vis[x][y])
    return d[x][y];
    vis[x][y] = 1;
    int maxn = 0;
    int x1,y1;
    for(int i = 0;i<4;++i)//四个方向
     for(int j = 1 ;j<=k;++j)//每次跳1-k次
       {
           x1 = x+dir[i][0]*j;
           y1 = y+dir[i][1]*j;
           if(x1>=0&&x1<n&&y1>=0&&y1<n&&grid[x1][y1]>grid[x][y])
           {
               int temp = dfs(x1,y1);
               maxn =  max(maxn,temp);//取这些所有可能性中的最大值
           }
       }
       d[x][y] = maxn + grid[x][y];
       return d[x][y];
}
int main()
{
    while(scanf("%d%d",&n,&k)==2)
    {
        if(n==-1&&k==-1)
        break;
        memset(d,0,sizeof(d));
        memset(vis,0,sizeof(vis));
        FOR(i,0,n)
         FOR(j,0,n)
         scanf("%d",&grid[i][j]);

        printf("%d\n",dfs(0,0));//从0.0开始遍历
    }
    return 0;
}

抱歉!评论已关闭.