现在的位置: 首页 > 综合 > 正文

Connect the Cities

2013年01月17日 ⁄ 综合 ⁄ 共 2055字 ⁄ 字号 评论关闭
Connect the Cities

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d
& %I64u

Appoint description: 

Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities
again, but they don’t want to take too much money.  
 

Input

The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected
cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input

1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output

1
简单的kruskal:
#include <stdlib.h>
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
#include <vector>
#define INF 1000000000
using namespace std;
const int maxn  =  250000 + 5;
int  w[maxn];
int v[maxn];
int u[maxn];
int parent[maxn];
int r[maxn];
int cmp(const int i,const int j)
{
    return w[i]<w[j];
}
int find(int x)
{
    if(parent[x]==x)
    return x;
    else
    {
        parent[x] = find(parent[x]);
        return parent[x];
    }
}

int  main()
{
    int T;
    scanf("%d",&T);
    for(int L = 0;L<T;++L)
    {
        int n,m,k;
        scanf("%d%d%d",&n,&m,&k);


        for(int i = 0;i<m;++i)
        {
            int p,q,c;
            scanf("%d%d%d",&p,&q,&c);
            w[i] = c;
            v[i] = q;
            u[i] = p;
        }

         for(int i = 0;i<m;++i)
          r[i] = i;

         sort(r,r+m,cmp);

        for(int i = 1;i<=n;++i)
         parent[i] = i;

        int count = 0;
        for(int i = 0;i<k;++i)
        {
           int t;
           scanf("%d",&t);
           int a;
           int b;
           scanf("%d",&b);
           for(int j = 1;j<t;++j)
           {
             scanf("%d",&a);
             int x = find(b);
             int y = find(a);
             if(x!=y)
             parent[y] = x;

           }
        }
        int ans = 0;

        for(int i = 0;i<m;++i)
        {
            int e = r[i];
            int x = find(u[e]);
            int y = find(v[e]);
            if(x != y)
            {
                ans+=w[e];
                parent[x] = y;
            }
        }
        for(int i = 1;i<=n;++i)
         if(parent[i] == i)
             count++;
          if(count==1)//如果可以形成通路那么集合代表元就只能有一个
          printf("%d\n",ans);
          else
          printf("-1\n");

    }
    return 0;
}

抱歉!评论已关闭.