现在的位置: 首页 > 综合 > 正文

Palindrome

2013年01月07日 ⁄ 综合 ⁄ 共 1708字 ⁄ 字号 评论关闭
Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 46767   Accepted: 15988

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

Source

没有啥要说的只有一个注意点。。。
d数组如果是int类型的一定会Memory Limit Exceeded
但是改成short int 就AC了
AC代码:
看到有的人使用滚动数组。。空间开销非常小,,,有机会试试
#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <sstream>
#include <vector>
#include <stack>
#include <map>
#include <queue>
#include <set>
#include <iostream>
#include <stdlib.h>
#include <cctype>
#define rep(i,s,e) for(int i = (s);i<(e);++i)
#define maxn 5001
#define INF 1000000000
#define eps 1e-6
using namespace std;
int n;
char A[maxn];
char B[maxn];
short int d[maxn][maxn];
int main()
{
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)==1)
    {
       scanf("%s",A);
       memset(d,0,sizeof(d));
       for(int i  = n-1;i>=0;--i)
        B[i] = A[n - 1 - i];

       for(int i = 1;i<=n;++i)
        for(int j = 1;j<=n;++j)
        {
            if(A[i-1] == B[j - 1])
            d[i][j] = d[i - 1][j - 1] + 1;
            else
            d[i][j] = max(d[i-1][j],d[i][j-1]);
        }
        cout<<n - d[n][n]<<endl;
    }
    return 0;
}

抱歉!评论已关闭.