现在的位置: 首页 > 综合 > 正文

DP

2013年12月26日 ⁄ 综合 ⁄ 共 4378字 ⁄ 字号 评论关闭


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1819    Accepted Submission(s): 1034


Problem Description
It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because
these can be used to diagnose human diseases and to design new drugs for them. 

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function. One of the methods for biologists to use in
determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes
and functions to the database and the database is freely accessible through the Internet. 

A database search will return a list of gene sequences from the database that are similar to the query gene. Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that
the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed. 

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one. 

Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of the genes to make them equally long and score
the resulting genes according to a scoring matrix. 

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal length. These two strings are aligned: 

AGTGAT-G 
-GT--TAG 

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.



* denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9. 

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions): 

AGTGATG 
-GTTA-G 

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the similarity of the two genes is 14.

 


Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence
is at least one and does not exceed 100. 
 


Output
The output should print the similarity of each test case, one per line. 
 


Sample Input
2 7 AGTGATG 5 GTTAG 7 AGCTATT 9 AGCTTTAAA
 


Sample Output
14 21
 


Source
 

/*
 * Author:  *******
 * Created Time:  2013/8/7 14:09:25
 * File Name: 初级IV.cpp
 * solve: 初级IV.cpp
 */
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<string>
#include<map>
#include<stack>
#include<set>
#include<iostream>
#include<vector>
#include<queue>

using namespace std;
#define sz(v) ((int)(v).size())
#define rep(i, n) for (int i = 0; i < (n); ++i)
#define repf(i, a, b) for (int i = (a); i <= (b); ++i)
#define repd(i, a, b) for (int i = (a); i >= (b); --i)
#define clr(x) memset(x,0,sizeof(x))
#define clrs( x , y ) memset(x,y,sizeof(x))
#define out(x) printf(#x" %d\n", x)
#define sqr(x) ((x) * (x))
typedef long long LL;

const int INF = -1u>>1;
const double eps = 1e-8;
const int maxn = 200;

char A[maxn];
char B[maxn];
int cmp[6][6] = {0,0,0,0,0,0,
                 0,5,-1,-2,-1,-3,
                 0,-1,5,-3,-2,-4,
                 0,-2,-3,5,-2,-2,
                 0,-1,-2,-2,5,-1,
                 0,-3,-4,-2,-1,-INF
                };

int getnum(char a)
{
    if(a == 'A')
        return 1;
    if(a == 'C')
        return 2;
    if(a == 'G')
        return 3;
    if(a == 'T')
        return 4;
    return 5;
}

int getcmp(char a,char b)
{
    int c = getnum(a);
    int d = getnum(b);
    return cmp[c][d];
}

int dp[maxn][maxn];//dp[i][j]代表第一个字符串匹配到第i个字符第2个字符串匹配到第j个字符时的结果

int main() 
{
   //freopen("in.txt","r",stdin);
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int a,b;
        scanf("%d%s",&a,A+1);
        scanf("%d%s",&b,B+1);

        memset(dp,0,sizeof(dp));

        for(int i = 1;i<=a;++i)
            dp[i][0] = dp[i-1][0] + getcmp(A[i],'-') ;

        for(int i = 1;i<=b;++i)
            dp[0][i] = dp[0][i-1] + getcmp('-',B[i]);
        
        for(int i = 1;i<=a;++i)
            for(int j = 1;j<=b;++j)
            {
                dp[i][j] = max(dp[i-1][j] + getcmp(A[i],'-'),max(dp[i][j-1] + getcmp('-',B[j]),dp[i-1][j-1] + getcmp(A[i],B[j])));
            }

        cout<<dp[a][b]<<endl;
    }
    return 0;
}

抱歉!评论已关闭.