现在的位置: 首页 > 综合 > 正文

杂题

2013年08月27日 ⁄ 综合 ⁄ 共 3088字 ⁄ 字号 评论关闭
Time Limit: 12000MS   Memory Limit: 65536K
Total Submissions: 2773   Accepted: 1105
Case Time Limit: 2000MS

Description

cellular automaton is a collection of cells on a grid of specified shape that evolves through a number of discrete time steps according to a set of rules that describe the new state of a cell based on the states of neighboring cells. The order
of the cellular automaton
 is the number of cells it contains. Cells of the automaton of order n are numbered from 1 to n.

The order of the cell is the number of different values it may contain. Usually, values of a cell of order m are considered to be integer numbers from 0 to m − 1.

One of the most fundamental properties of a cellular automaton is the type of grid on which it is computed. In this problem we examine the special kind of cellular automaton — circular cellular automaton of order n with cells of order m.
We will denote such kind of cellular automaton as n,m-automaton.

A distance between cells i and j in n,m-automaton is defined as min(|i − j|, n − |i − j|). A d-environment of a cell is the set of cells at a distance not greater than d.

On each d-step values of all cells are simultaneously replaced by new values. The new value of cell i after d-step is computed as a sum of values of cells belonging to the d-enviroment of the cell i modulo m.

The following picture shows 1-step of the 5,3-automaton.

The problem is to calculate the state of the n,m-automaton after k d-steps.

Input

The first line of the input file contains four integer numbers nmd, and k (1 ≤ n ≤ 500, 1 ≤ m ≤ 1 000 000, 0 ≤ d < n2 , 1 ≤ k ≤ 10 000 000). The second
line contains n integer numbers from 0 to m − 1 — initial values of the automaton’s cells.

Output

Output the values of the n,m-automaton’s cells after k d-steps.

Sample Input

sample input #1
5 3 1 1
1 2 2 1 2

sample input #2
5 3 1 10
1 2 2 1 2

Sample Output

sample output #1
2 2 2 2 1

sample output #2
2 0 0 2 2

Source

没有进行细节的优化跑了6000+ms
/*
 * Author:  ********
 * Created Time:  2013/8/11 19:31:43
 * File Name: auto.cpp
 * solve: auto.cpp
 */
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<cmath>
#include<algorithm>
#include<string>
#include<map>
#include<stack>
#include<set>
#include<iostream>
#include<vector>
#include<queue>

using namespace std;
#define sz(v) ((int)(v).size())
#define rep(i, n) for (int i = 0; i < (n); ++i)
#define repf(i, a, b) for (int i = (a); i <= (b); ++i)
#define repd(i, a, b) for (int i = (a); i >= (b); --i)
#define clr(x) memset(x,0,sizeof(x))
#define clrs( x , y ) memset(x,y,sizeof(x))
#define out(x) printf(#x" %d\n", x)
#define sqr(x) ((x) * (x))
typedef long long LL;

const int INF = -1u>>1;
const double eps = 1e-8;
const int maxn = 505;

int n,m,d,k;

//LL first[maxn];

struct matrix
{
    LL temp[maxn][maxn];
    void set0()
    {
        memset(temp,0,sizeof(temp));
    }
}p,first,ans;

matrix mul(matrix m1,matrix m2)
{
    matrix tmp;
    tmp.set0();
    for(int i = 0;i<n;++i)
        for(int j = 0;j<n;++j)
        {
            tmp.temp[0][i] = (tmp.temp[0][i] + m1.temp[0][j] * m2.temp[j][i])%m;
        }
    
    for(int i = 1;i<n;++i)
        for(int j = 0;j<n;++j)
        {
            tmp.temp[i][j] = tmp.temp[i-1][(j-1+n)%n];
        }
    return tmp;
}
int main() 
{
   
    while(scanf("%d%d%d%d",&n,&m,&d,&k) == 4)
    {
        first.set0();
        for(int i  = 0;i<n;++i)
            scanf("%lld",&first.temp[0][i]);

        p.set0();

        for(int i = 0;i<n;++i)
            for(int j = 0;j<n;++j)
            {
                if(min(abs(i-j), n - abs(i - j)) <= d)
                {
                    p.temp[i][j] = 1;
                }
            }

        ans.set0();
        for(int i = 0;i<n;++i)
            ans.temp[i][i] = 1;

        while(k)
        {
            if(k&1)
            {
                ans = mul(ans,p);
            }
            k>>=1;
            p = mul(p,p);
        }

        first = mul(first,ans);

        for(int i  = 0;i<n-1;++i)
            printf("%lld ",first.temp[0][i]);
        
        printf("%lld\n",first.temp[0][n-1]);

    }
    
    return 0;
}

抱歉!评论已关闭.