现在的位置: 首页 > 综合 > 正文

HDOJ More is better

2013年07月12日 ⁄ 综合 ⁄ 共 2231字 ⁄ 字号 评论关闭
文章目录

 

  More is better 

http://acm.hdu.edu.cn/diy/contest_showproblem.php?pid=1003&cid=12467&hide=0

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 327680/102400K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 4

Font: Times New Roman | Verdana | Georgia

Font Size:

Problem Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex,the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are
still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A
≠ B, 1 ≤ A, B ≤ 10000000)

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input

4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output

4
2

Hint

A and B are friends(direct or indirect), B and C are friends(direct or indirect),
then A and C are also friends(indirect).

In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

Author

lxlcrystal@TJU

Source

HDU 2007 Programming Contest - Final
 
 
代码如下:
 

#include<iostream>
#include<algorithm>
using namespace std;
#define N 100005
int parent[N+5];
int height[N+5];
void init(){
     for(int i=1;i<=N;i++){
     parent[i]=i;
     height[i]=1;
     }
}
int find(int x){
    while(x!=parent[x])
    x=parent[x];
    return x;
}
void merge(int x,int y,int *max){
     x=find(x);
     y=find(y);
     if(x==y)
     return ;
     else if(height[x]==height[y]){
     parent[y]=x;
     height[x]+=height[y];
     }
     else if(height[x]<height[y]){
     parent[x]=y;
     height[y]+=height[x];
     }
     else{
     parent[y]=x;
     height[x]+=height[y];
     }
     if(*max<(height[x]>height[y]?height[x]:height[y]))
     *max=(height[x]>height[y]?height[x]:height[y]);
}

int main(){
   
    int max=1;
    int n,a,b;
   while( scanf("%d",&n)!=EOF){
    init();
    max=1;
    while(n--){
               scanf("%d %d",&a,&b);
               merge(a,b,&max);
               }

    printf("%d\n",max);
}

        return 0;
   
}

 
 
 

抱歉!评论已关闭.