现在的位置: 首页 > 综合 > 正文

HDU-1162(最小生成树)

2013年03月23日 ⁄ 综合 ⁄ 共 2130字 ⁄ 字号 评论关闭

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4774    Accepted Submission(s): 2372


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends
are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?
 


Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.

 


Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 


Sample Input
3 1.0 1.0 2.0 2.0 2.0 4.0
 


Sample Output
3.41
 


Author
eddy
 


Recommend
JGShining

这也是一道很简单的,很裸的Minimal Spanning Tree,

贴出代码;

#include <stdio.h>
#include <string.h>
#include <math.h>
#include <iostream>
#include <string>

using namespace std;

const double INF = 11111111111111111.0;

int N;

struct Point
{
	double x;
	double y;
}p[105];

double map[105][105];

int vis[105];

double dis[105];

void Init()
{
	memset(vis, 0, sizeof(vis));
	for (int i = 1; i <= N; i++)
	{
		dis[i] = INF;
	}
}

double Distance(int i , int j)
{
	return sqrt((p[j].x - p[i].x) * (p[j].x - p[i].x) + (p[j].y - p[i].y) * (p[j].y - p[i].y));
}

double Prim()
{
	dis[1] = 0;
	for (int i = 1; i <= N; i++)
	{
		int pos;
		double t = INF;
		for (int j = 1; j <= N; j++)
		{
			if (!vis[j] && t > dis[j])
			{
				pos = j;
				t = dis[j];
			}
		}
		vis[pos] = 1;
		for (int j = 1; j <= N; j++)
		{
			if (!vis[j] && dis[j] > map[pos][j])
			{
				dis[j] = map[pos][j];
			}
		}
	}
	double sum = 0;
	for (int i = 1; i <= N; i++)
	{
		sum += dis[i];
	}
	return sum;
}
	

int main()
{
	while (scanf("%d", &N) != EOF)
	{
		Init();
		for (int i = 1; i <= N; i++)
		{
			scanf("%lf%lf", &p[i].x, &p[i].y);
		}
		for (int i = 1; i <= N; i++)
		{
			for (int j = i + 1;j <= N; j++)
			{
				double t = Distance(i, j);
				map[i][j] = t;
				map[j][i] = t;
			}
		}
		double ans = Prim();
		printf("%.2lf\n", ans);
	} 
//	system("pause");
	return 0;
}

抱歉!评论已关闭.