现在的位置: 首页 > 综合 > 正文

hdu 1423 Greatest Common Increasing Subsequence (最长上升子序列)

2013年08月13日 ⁄ 综合 ⁄ 共 1213字 ⁄ 字号 评论关闭

1、http://acm.hdu.edu.cn/showproblem.php?pid=1423

参考百度文库http://wenku.baidu.com/view/3e78f223aaea998fcc220ea0.html

2、题目大意:

求两个字符串的最大上升子序列,LCIS解决即可

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2116    Accepted Submission(s): 638

Problem Description
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

 

Input
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

 

Output
output print L - the length of the greatest common increasing subsequence of both sequences.

 

Sample Input
1 5 1 4 2 5 -12 4 -12 1 2 4

 

Sample Output
2

3、代码:

#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
    int t,m,n,a[600],b[600],dp[601][601],i,j,max;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
           scanf("%d",&a[i]);
            scanf("%d",&m);
           for(i=0;i<m;i++)
           scanf("%d",&b[i]);
           memset(dp,0,sizeof(dp));

           for(i=0;i<n;i++)
           {
               max=0;
               for(j=0;j<m;j++)
               {
                dp[i+1][j+1]=dp[i][j+1];
                if(a[i]>b[j]&&max<dp[i+1][j+1])
                  max=dp[i+1][j+1];
                  if(a[i]==b[j])
                  dp[i+1][j+1]=max+1;

               }
           }
           //printf("%d\n",m);
           //for(i=0;i<=m;i++)
            //printf("%d\n",dp[n][i]);
           max=*max_element(dp[n],dp[n]+m+1);
           printf("%d\n",max);
           if(t!=0)
            printf("\n");

    }
    return 0;
}

抱歉!评论已关闭.