现在的位置: 首页 > 综合 > 正文

POJ1458 Common Subsequence

2013年05月27日 ⁄ 综合 ⁄ 共 1350字 ⁄ 字号 评论关闭
Common Subsequence
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 30903   Accepted: 12045

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

Source

这是一个LCS的问题,至于LCS是什么,你百度吧。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
using namespace std;
int main()
{
    string a,b;
    int f[1000][1000];
    while(cin>>a>>b)
    {
        int m=a.length();
        int n=b.length();
        for(int i=0;i<=m;i++)f[0][i]=0;
        for(int j=0;j<=n;j++)f[j][0]=0;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(a[j-1]==b[i-1])f[i][j]=f[i-1][j-1]+1;
                else f[i][j]=max(f[i][j-1],f[i-1][j]);
            }
        }
        cout<<f[n][m]<<endl;
    }
    return 0;
}

抱歉!评论已关闭.