现在的位置: 首页 > 综合 > 正文

POJ1050 To the Max

2013年09月10日 ⁄ 综合 ⁄ 共 1516字 ⁄ 字号 评论关闭
To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33640   Accepted: 17607

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the
sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines).
These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

Source

这是一个最大子段和的二维变形。将其转化为一维的就简单多了,看代码你就懂了。
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    int n,a[101][101],f[101],ma=-200;
    scanf("%d",&n);
    memset(a,0,sizeof(a));
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=n;j++)
        {
            scanf("%d",&a[i][j]);
            a[i][j]+=a[i-1][j];
        }
    }
    for(int i=0;i<n;i++)
    {
        for(int j=i+1;j<=n;j++)
        {
            memset(f,0,sizeof(f));
            for(int x=1;x<=n;x++)
            {
                if(f[x-1]>0)f[x]=f[x-1]+a[j][x]-a[i][x];
                else f[x]=a[j][x]-a[i][x];
                if(f[x]>ma)ma=f[x];
            }
        }
    }
    cout<<ma<<endl;
    return 0;
}

抱歉!评论已关闭.