现在的位置: 首页 > 综合 > 正文

POJ3067 Japan

2013年03月07日 ⁄ 综合 ⁄ 共 1773字 ⁄ 字号 评论关闭
Japan
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15663   Accepted: 4211

Description

Japan plans to welcome the ACM ICPC World Finals and a lot of roads must be built for the venue. Japan is tall island with N cities on the East coast and M cities on the West coast (M <= 1000, N <= 1000). K superhighways will be build. Cities on each coast
are numbered 1, 2, ... from North to South. Each superhighway is straight line and connects city on the East coast with city of the West coast. The funding for the construction is guaranteed by ACM. A major portion of the sum is determined by the number of
crossings between superhighways. At most two superhighways cross at one location. Write a program that calculates the number of the crossings between superhighways.

Input

The input file starts with T - the number of test cases. Each test case starts with three numbers – N, M, K. Each of the next K lines contains two numbers – the numbers of cities connected by the superhighway. The first one is the number of the city on the
East coast and second one is the number of the city of the West coast.

Output

For each test case write one line on the standard output: 
Test case (case number): (number of crossings)

Sample Input

1
3 4 4
1 4
2 3
3 2
3 1

Sample Output

Test case 1: 5

Source

这是一道树状数组的题目,其实和2352类似,在2352的基础上想想就可以AC了,注意结果用long long int
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
    int x,y;
}p[1000001];
int c[1001],n,m,k,t;
long long int ans;
int lowbit(int i)
{
    return i&(-i);
}
bool cmp(node aa,node bb)
{
    if(aa.x==bb.x)return aa.y<bb.y;
    else return aa.x<bb.x;
}
int sum(int i)
{
    int s=0;
    while(i<=1000)
    {
        s+=c[i];
        i+=lowbit(i);
    }
    return s;
}
void ad(int i)
{
    while(i>0)
    {
        c[i]++;
        i-=lowbit(i);
    }
}
int main()
{
    scanf("%d",&t);
    for(int num=1;num<=t;num++)
    {
        memset(c,0,sizeof(c));
        scanf("%d%d%d",&m,&n,&k);
        for(int i=0;i<k;i++)scanf("%d%d",&p[i].x,&p[i].y);
        sort(p,p+k,cmp);
        ans=0;
        for(int i=0;i<k;i++)
        {
            ans+=sum(p[i].y+1);
            ad(p[i].y);
        }
        cout<<"Test case "<<num<<": "<<ans<<endl;
    }
    return 0;
}
【上篇】
【下篇】

抱歉!评论已关闭.