现在的位置: 首页 > 综合 > 正文

HDU What Are You Talking About

2014年02月05日 ⁄ 综合 ⁄ 共 2846字 ⁄ 字号 评论关闭
Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 102400/204800K (Java/Other)
Total Submission(s) : 23   Accepted Submission(s) : 12
Problem Description
Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?
 


Input
The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.
 


Output
In this problem, you have to output the translation of the history book.
 


Sample Input
START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END
 


Sample Output
hello, i'm from mars. i like earth
赤裸的字典树,套用模板即可。

#include<iostream>
using namespace std;
struct node
{
struct node *child[26];
char *str;
}*root;
void  insert(char *c1,char *c2)
{
int len=strlen(c2);
struct node *cur,*newnode;
cur=root;
for(int i=0;i<len;i++)
{
if(cur->child[c2[i]-'a']!=0)
cur=cur->child[c2[i]-'a'];
else {
newnode=new struct node;
cur->child[c2[i]-'a']=newnode;
for(int j=0;j<26;j++)
newnode->child[j]=0;
newnode->str=NULL;
cur=newnode;
}
}
cur->str=new char[15];
strcpy(cur->str,c1);
}
void find_print(char *c2)
{
int len=strlen(c2);
struct node*cur;
cur=root;
if(!len ) return ;
for(int i=0;i<len;i++)
{
if(c2[i]<'a'||c2[i]>'z'||cur->child[c2[i]-'a']==0){
printf("%s",c2);
return ;
}
else cur=cur->child[c2[i]-'a'];
}
if(cur->str!=NULL)
printf("%s",cur->str);
else
printf("%s",c2);

}
int main()
{
char s[15],temp[3005],c1[15],c2[15];
root=new struct node;
for(int  i=0;i<26;i++)
root->child[i]=0;
scanf("%s",temp);
while(scanf("%s",c1)&&strcmp(c1,"END")!=0)
{
scanf("%s",c2);
insert(c1,c2);
}
scanf("%s",temp);
getchar();
while(gets(temp)&&strcmp(temp,"END")!=0)
{
int len=strlen(temp);
int num=0;
bool flag=false;
for(int i=0;i<len;i++)
{
if(temp[i]>='a'&&temp[i]<='z'){
if(flag==false) flag=true;
s[num++]=temp[i];
}
else{
if(flag){
flag=false;
s[num]='\0';
num=0;
find_print(s);
}
printf("%c",temp[i]);
}
}
if(flag){
s[num]='\0';
find_print(s);
}
printf("\n");
}
return 0;

}

抱歉!评论已关闭.