现在的位置: 首页 > 综合 > 正文

【计算几何】Wall

2014年01月15日 ⁄ 综合 ⁄ 共 3494字 ⁄ 字号 评论关闭
Description
Once upon a time there was a greedy King who ordered his chief Architect to build a wall around
the King's castle. The King was so greedy, that he would not listen to his Architect's proposals
to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to
build the wall around the whole castle using the least amount of stone and labor, but demanded
that the wall should not come closer to the castle than a certain distance. If the King finds
that the Architect has used more resources to build the wall than it was absolutely necessary
to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded
Architect to introduce at once a plan of the wall listing the exact amount of resources that
are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the
minimum possible length of the wall that he could build around the castle to satisfy King's
requirements.

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and
is situated on a flat ground. The Architect has already established a Cartesian coordinate
system and has precisely measured the coordinates of all castle's vertices in feet.

Input
The first line of the input file contains two integer numbers N and L separated by a space.
N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is
the minimal number of feet that King allows for the wall to come close to the castle.

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains
two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent
the coordinates of ith vertex. All vertices are different and the sides of the castle do not
intersect anywhere except for vertices.

Output
Write to the output file the single number that represents the minimal possible length of the
wall in feet that could be built around the castle to satisfy King's requirements. You must
present the integer number of feet to the King, because the floating numbers are not invented
yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot
is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output
1628

这是一道凸包的入门题。
先将所有点按纵坐标从小到大排序,若纵坐标相同则按横坐标从小到大排序。

接着从头到尾扫描,保证每条边都在上一条边的逆时针方向(用栈来维护),得到凸包的右半集;再从尾到头扫描,同时保证每条边都在上一条边的逆时针方向,得到凸包的右半集部分。

由于这时栈顶多了一个首元素,所以舍弃栈顶。

Accode:

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <complex>

using std::complex;
const char fi[] = "wall.in";
const char fo[] = "wall.out";
const int maxN = 1010;
const int MAX = 0x3f3f3f3f;
const int MIN = ~MAX;
const double zero = 1e-12;
const double Pi = asin(1.L) * 2.L;

typedef complex <double> Point;
Point p[maxN];
Point res[maxN];
int n, R, top;

void init_file()
{
    freopen(fi, "r", stdin);
    freopen(fo, "w", stdout);
    return;
}

void readdata()
{
    scanf("%d%d", &n, &R);
    for (int i = 0; i < n; ++i)
    {
        double x, y;
        scanf("%lf%lf", &x, &y);
        p[i] = Point(x, y);
    }
    return;
}

template <typename _Tp>
_Tp outer_product(const complex <_Tp> a,
                  const complex <_Tp> b)
{
    return a.real() * b.imag()
    - a.imag() * b.real();
}

int cmp(const void *a, const void *b)
{
    Point A = *(Point *)a,
    B = *(Point *)b;
    if (A.imag() < B.imag() - zero) return -1;
    if (A.imag() > B.imag() + zero) return 1;
    if (A.real() < B.real() - zero) return -1;
    if (A.real() > B.real() + zero) return 1;
    return 0;
}

void work()
{
    qsort(p, n, sizeof(p[0]), cmp);
    res[0] = p[0];
    res[1] = p[1];
    top = 1;
    for (int i = 2; i < n; ++i)
    {
        while (top &&
               outer_product(p[i] - res[top],
               res[top] - res[top - 1]) > -zero)
            --top;
        res[++top] = p[i];
    }
    int tmp = top;
    res[++top] = p[n - 2];
    for (int i = n - 3; i > -1; --i)
    {
        while (top > tmp &&
               outer_product(p[i] - res[top],
               res[top] - res[top - 1]) > -zero)
            --top;
        res[++top] = p[i];
    }
    double ans = Pi * (R << 1)
    + abs(res[0] - res[top - 1]);
    for (int i = 1; i < top; ++i)
        ans += abs(res[i] - res[i - 1]);
    printf("%d\n", (int)(ans + 0.5));
    return;
}

int main()
{
    init_file();
    readdata();
    work();
    return 0;
}

抱歉!评论已关闭.