现在的位置: 首页 > 综合 > 正文

To the Max

2014年01月09日 ⁄ 综合 ⁄ 共 1507字 ⁄ 字号 评论关闭
To the Max
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 28700   Accepted: 14919

Description

Given a two-dimensional array of positive and negative  integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater  located within the whole array. The sum of a rectangle is the sum of all the  elements in that
rectangle. In this problem the sub-rectangle with the largest  sum is referred to as the maximal sub-rectangle.

As an example, the maximal  sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1  8 0 -2
is in the lower left corner:

9 2
-4 1
-1 8
and  has a sum of 15.

Input

The input consists of an N * N array of integers. The  input begins with a single positive integer N on a line by itself, indicating  the size of the square two-dimensional array. This is followed by N^2 integers  separated by
whitespace (spaces and newlines). These are the N^2 integers of the  array, presented in row-major order. That is, all numbers in the first row, left  to right, then all numbers in the second row, left to right, etc. N may be as  large as 100. The numbers
in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15
http://poj.org/problem?id=1050
很典型的动态规划的题目,这道题我是用了枚举+动态规划的方法完成的,先枚举目标矩阵的起始和结束行,再计算出每一列的数据的和,变化为求最大子段和,再利用动态规划求最大子段和,只需求出各种情况下的最大子段和即可。
 
#include <iostream>
using namespace std;

#define MAX 100

int main()
{
	int n,i,j,k,sum=-12800;
	int squma[MAX][MAX]={0};
	int linesum[MAX][MAX]={0};
    cin>>n;
	for (i=0;i<n;++i)
		for (j=0;j<n;++j)
			cin>>squma[i][j];
	for (i=0;i<n;++i)
		for (j=i;j<n;++j)
		{
			int b=0;
			for (k=0;k<n;++k)
			{
				linesum[i][k]+=squma[j][k];
				if (b>0)
					b+=linesum[i][k];
				else
					b=linesum[i][k];
				if (b>sum)
					sum=b;
			}
		}
	cout<<sum;
	return 0;
}

抱歉!评论已关闭.