现在的位置: 首页 > 综合 > 正文

hdu 4336 Card Collector (容斥原理)

2014年02月19日 ⁄ 综合 ⁄ 共 1799字 ⁄ 字号 评论关闭

Card Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1715    Accepted Submission(s): 786

Special Judge

Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

 

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility
of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.

 

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.

 

Sample Input
1 0.1 2 0.1 0.4
 

Sample Output
10.000 10.500
 

Source

题意:

买东西集齐全套卡片赢大奖。每个包装袋里面有一张卡片或者没有。

已知每种卡片出现的概率 p[i],以及所有的卡片种类的数量 n(1<=n<=20)。

问集齐卡片需要买东西的数量的期望值。

思路:

容斥原理,dfs实现,但是还是不太懂,那个两个集合的交集应该这么算: 1/(p[i]+p[j]),以后懂了再解释。路过的大神也可以给我讲一下。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 25
using namespace std;

int n,m;
double ans,sum;
double a[maxn];

void dfs(int len,int pos,int cnt,double s)  // 卡片个数、当前卡片的下标、已经有的卡片、已有卡片的概率
{
    if(cnt==len)
    {
        sum+=1.0/s;  
        return ;
    }
    if(pos>n) return ;
    dfs(len,pos+1,cnt+1,s+a[pos]);
    dfs(len,pos+1,cnt,s);
}
int main()
{
    int i,j;
    while(~scanf("%d",&n))
    {
        ans=0;
        for(i=1; i<=n; i++)
        {
            scanf("%lf",&a[i]);
            ans+=1.0/a[i];
        }
        for(i=2; i<=n; i++)
        {
            sum=0;
            dfs(i,1,0,0);
            if(i%2==0) ans-=sum;  // 减偶
            else ans+=sum;        // 加奇
        }
        printf("%.6f\n",ans);
    }
    return 0;
}


 

抱歉!评论已关闭.