现在的位置: 首页 > 综合 > 正文

hdu 1074 Doing Homework (状压dp)

2014年02月16日 ⁄ 综合 ⁄ 共 2399字 ⁄ 字号 评论关闭

Doing Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4149    Accepted Submission(s): 1668

Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce
his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject),
C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

 

Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
 

Sample Input
2 3 Computer 3 3 English 20 1 Math 3 2 3 Computer 3 3 English 6 3 Math 6 3
 

Sample Output
2 Computer Math English 3 Computer English Math
Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.
 

Author
Ignatius.L
思路:
初看题目,肯定会头疼,根本不知道怎样建状态,更不用说转移方程了。
n只有15,想到状态压缩,用0~1<<15可以将所有状态都表示出来,每一位与每一个科目对应,1表示做了,0表示没做,那么就好状态转移了,每次转移的时候保证得到的罚分最小就够了。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 1<<15
#define INF 0x3f3f3f3f
using namespace std;

int n,m,ans;
struct node
{
    int d,c;
    char s[105];
}q[20];
struct Node
{
    int now,pre;
    int time,rs;
}dp[maxn];

void solve()
{
    int i,j,st,time,rs;
    for(i=1;i<=m;i++)
    {
        dp[i].rs=INF;
    }
    dp[0].time=0;
    for(i=0;i<=m;i++)
    {
        for(j=0;j<n;j++)
        {
            if(!(i&(1<<j)))
            {
                st=i|(1<<j);
                time=dp[i].time+q[j].c;
                rs=max(0,time-q[j].d);
                rs+=dp[i].rs;
                if(dp[st].rs>rs)
                {
                    dp[st].time=time;
                    dp[st].rs=rs;
                    dp[st].now=j;
                    dp[st].pre=i;
                }
            }
        }
    }
}
void output(int k)
{
    if(k==0) return ;
    output(dp[k].pre);
    printf("%s\n",q[dp[k].now].s);
}
int main()
{
    int i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        m=(1<<n)-1;
        for(i=0;i<n;i++)
        {
            scanf("%s%d%d",q[i].s,&q[i].d,&q[i].c);
        }
        solve();
        printf("%d\n",dp[m].rs);
        output(m);
    }
    return 0;
}


 

抱歉!评论已关闭.