现在的位置: 首页 > 综合 > 正文

hdu1851 A Simple Game—–sg

2014年02月13日 ⁄ 综合 ⁄ 共 1907字 ⁄ 字号 评论关闭

A Simple Game

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/65535 K (Java/Others)
Total Submission(s): 674    Accepted Submission(s): 395

Problem Description
Agrael likes play a simple game with his friend Animal during the classes. In this Game there are n piles of stones numbered from 1 to n, the 1st pile has M1 stones, the 2nd pile has
M2 stones, ... and the n-th pile contain Mn stones. Agrael and Animal take turns to move and in each move each of the players can take at most L1
stones from the 1st pile or take at most L2 stones from the 2nd pile or ... or take Ln stones from the n-th pile. The player who takes the last stone wins.

After Agrael and Animal have played the game for months, the teacher finally got angry and decided to punish them. But when he knows the rule of the game, he is so interested in this game that he asks Agrael to play the game with him and if Agrael wins, he
won't be punished, can Agrael win the game if the teacher and Agrael both take the best move in their turn?

The teacher always moves first(-_-), and in each turn a player must takes at least 1 stones and they can't take stones from more than one piles.

Input
The first line contains the number of test cases. Each test cases begin with the number n (n ≤ 10), represent there are n piles. Then there are n lines follows, the i-th line contains two numbers Mi
and Li (20 ≥ Mi > 0, 20 ≥ Li > 0).

Output
Your program output one line per case, if Agrael can win the game print "Yes", else print "No".

Sample Input
2 1 5 4 2 1 1 2 2

Sample Output
Yes No

Author
Agreal@TJU

Source
HDU 2007 Programming Contest - Final
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
using namespace std;
int fibo[15];
int num[15];
int n;
int f[20];
int mex(int x,int i)
{
    bool g[20]={0};
    for(int j=1;j<=i;j++)
    {
        int t=x-j;
        if(t<0)
        break;
        if(f[t]==-1)
        f[t]=mex(t,i);
        g[f[t]]=1;

    }
    for(int j=0;;j++)
    {
        if(g[j]==0) return j;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        scanf("%d%d",&num[i],&fibo[i]);
        int ans=0;
        for(int i=0;i<n;i++)
        {
            memset(f,-1,sizeof(f));
            f[0]=0;
            f[num[i]]=mex(num[i],fibo[i]);
            //cout<<f[num[i]]<<"*"<<endl;
            ans^=f[num[i]];
        }
        if(ans!=0)
        puts("No");
        else
        puts("Yes");
    }
}
/*
Sample Input
2
1
5 4
2
1 1
2 2


Sample Output
Yes
No
*/

抱歉!评论已关闭.