现在的位置: 首页 > 综合 > 正文

hdu2516 取石子游戏

2014年01月07日 ⁄ 综合 ⁄ 共 617字 ⁄ 字号 评论关闭

取石子游戏

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2146 Accepted Submission(s): 1237

Problem Description
1堆石子有n个,两人轮流取.先取者第1次可以取任意多个,但不能全部取完.以后每次取的石子数不能超过上次取子数的2倍。取完者胜.先取者负输出"Second win".先取者胜输出"First win".

Input
输入有多组.每组第1行是2<=n<2^31. n=0退出.

Output
先取者负输出"Second win". 先取者胜输出"First win".
参看Sample Output.

Sample Input
2 13 10000 0

Sample Output
Second win Second win First win
找规律的题!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;

int main()
{
    int a,b,n;
    while(scanf("%d",&n)!=EOF&&n){
        a=1;b=1;
        while(b<n){
            a=a+b;
            swap(a,b);
        }
        if(b==n){
            printf("Second win\n");
        }
        else printf("First win\n");
    }
    return 0;
}

抱歉!评论已关闭.