现在的位置: 首页 > 综合 > 正文

HDU3415:Max Sum of Max-K-sub-sequence(单调队列)

2013年01月27日 ⁄ 综合 ⁄ 共 2135字 ⁄ 字号 评论关闭
Problem Description
Given a circle sequence A[1],A[2],A[3]......A[n]. Circle sequence means the left neighbour of A[1] is A[n] , and the right neighbour of A[n] is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.
 


Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. 
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).
 


Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the
minimum start position, if still more than one , output the minimum length of them.
 


Sample Input
4 6 3 6 -1 2 -6 5 -5 6 4 6 -1 2 -6 5 -5 6 3 -1 2 -6 5 -5 6 6 6 -1 -1 -1 -1 -1 -1
 


Sample Output
7 1 3 7 1 3 7 6 2 -1 1 1
 

 

这是我们集训比赛的一道题,出题人说是什么DP,坑爹啊,比赛完后一看,单调队列,DP还做不出来

然后就果断看了一下单调队列,之是参考别人的代码后才写出来的

 

单调队列即保持队列中的元素单调递增(或递减)的这样一个队列,可以从两头删除,只能从队尾插入。单调队列的具体作用在于,由于保持队列中的元素满足单调性,对于上述问题中的每个j,可以用O(1)的时间找到对应的s[i]。(保持队列中的元素单调增的话,队首元素便是所要的元素了)。

维护方法:对于每个j,我们插入s[j-1](为什么不是s[j]? 队列里面维护的是区间开始的下标,j是区间结束的下标),插入时从队尾插入。为了保证队列的单调性,我们从队尾开始删除元素,直到队尾元素比当前需要插入的元素优(本题中是值比待插入元素小,位置比待插入元素靠前,不过后面这一个条件可以不考虑),就将当前元素插入到队尾。之所以可以将之前的队列尾部元素全部删除,是因为它们已经不可能成为最优的元素了,因为当前要插入的元素位置比它们靠前,值比它们小。我们要找的,是满足(i>=j-k+1)的i中最小的s[i],位置越大越可能成为后面的j的最优s[i]。

在插入元素后,从队首开始,将不符合限制条件(i>=j-k+1)的元素全部删除,此时队列一定不为空。(因为刚刚插入了一个一定符合条件的元素)

 

#include <stdio.h>
#include <queue>
#include <algorithm>
#include <string.h>
using namespace std;

int a[111111];
int sum[211111];
const int INF = 0x3fffffff;

int main()
{
    int t,n,m,i,j,k,head,end;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&k);
        j = n;
        sum[0] = 0;
        for(i = 1; i<=n; i++)
        {
            scanf("%d",&a[i]);
            sum[i] = sum[i-1]+a[i];//将前i项和全部存入sum数组中
        }
        int ans = -INF;
        for(i = n+1; i<n+k;i++)
            sum[i] = sum[i-1]+a[i-n];
        n = n+k-1;
        deque<int> Q;//双向队列
        Q.clear();
        for(i = 1; i<=n; i++)
        {
            while(!Q.empty() && sum[i-1]<sum[Q.back()])//保持队列的单调性
                Q.pop_back();
            while(!Q.empty() && Q.front()<i-k)//超过k的长度则消除队列前面的元素
                Q.pop_front();
            Q.push_back(i-1);
            if(sum[i]-sum[Q.front()]>ans)//记录,sum[n]-sum[m]所得出的是n-1到m+1之间的和
            {
                ans = sum[i]-sum[Q.front()];
                head = Q.front()+1;
                end = i;
            }
        }
        if(end>j)
        end%=j;
        printf("%d %d %d\n",ans,head,end);
    }

    return 0;
}

 

 

抱歉!评论已关闭.