现在的位置: 首页 > 综合 > 正文

HDU1009:FatMouse’ Trade

2014年03月21日 ⁄ 综合 ⁄ 共 1372字 ⁄ 字号 评论关闭
Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.
 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

Sample Output
13.333 31.500
 

 

贪心= =

按性价比排序,然后再拿总猫粮去诱惑猫,并取得食物

 

#include <stdio.h>
#include <algorithm>
using namespace std;

struct Node
{
    double j,f,p;
} node[10000];

int cmp(Node x,Node y)
{
    return x.p>y.p;
}

int main()
{
    int m,n;
    while(~scanf("%d%d",&n,&m) && (m!=-1 || n!=-1))
    {
        double sum = 0,max = 0;
        int i,j;
        for(i = 0; i<m; i++)
        {
            scanf("%lf%lf",&node[i].j,&node[i].f);
            node[i].p = node[i].j/node[i].f;
        }
        sort(node,node+m,cmp);
        for(i = 0; i<m; i++)
        {
            if(n>node[i].f)
            {
                sum+=node[i].j;
                n-=node[i].f;
            }
            else
            {
                sum+=node[i].p*n;
                break;
            }
        }
        printf("%.3lf\n",sum);
    }

    return 0;
}

 

抱歉!评论已关闭.